Bug 1001235 - lxc : duplicate documentation files / potentially conflicting
lxc : duplicate documentation files / potentially conflicting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lxc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-26 15:53 EDT by Michael Schwendt
Modified: 2013-09-04 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 14:09:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-26 15:53:52 EDT
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> lxc-0.8.0-3.fc20.src.rpm
=> lxc-doc-0.8.0-3.fc20.i686 in fedora-development-i386
  File conflict with: lxc-0.8.0-3.fc20.i686
     /usr/share/doc/lxc/AUTHORS
     /usr/share/doc/lxc/COPYING
     /usr/share/doc/lxc/README
     /usr/share/doc/lxc/examples/lxc-complex.conf
     /usr/share/doc/lxc/examples/lxc-empty-netns.conf
     /usr/share/doc/lxc/examples/lxc-macvlan.conf
     /usr/share/doc/lxc/examples/lxc-no-netns.conf
     /usr/share/doc/lxc/examples/lxc-phys.conf
     /usr/share/doc/lxc/examples/lxc-veth.conf
     /usr/share/doc/lxc/examples/lxc-vlan.conf

=> lxc-0.8.0-3.fc20.src.rpm
=> lxc-0.8.0-3.fc20.i686 in fedora-development-i386
  File conflict with: lxc-doc-0.8.0-3.fc20.i686
     /usr/share/doc/lxc/AUTHORS
     /usr/share/doc/lxc/COPYING
     /usr/share/doc/lxc/README
     /usr/share/doc/lxc/examples/lxc-complex.conf
     /usr/share/doc/lxc/examples/lxc-empty-netns.conf
     /usr/share/doc/lxc/examples/lxc-macvlan.conf
     /usr/share/doc/lxc/examples/lxc-no-netns.conf
     /usr/share/doc/lxc/examples/lxc-phys.conf
     /usr/share/doc/lxc/examples/lxc-veth.conf
     /usr/share/doc/lxc/examples/lxc-vlan.conf
Comment 1 Thomas Moschny 2013-09-04 14:09:58 EDT
Fixed in lxc-0.9.0-2.fc20 and lxc-0.9.0-2.fc21. The only duplicated files are README, AUTHORS, and COPYING, the latter being required by the package guidelines.

Note You need to log in before you can comment on or make changes to this bug.