Bug 1001246 - libXt : duplicate documentation files / potentially conflicting
libXt : duplicate documentation files / potentially conflicting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-26 15:55 EDT by Michael Schwendt
Modified: 2014-06-18 05:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-14 07:01:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-26 15:55:17 EDT
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> libXt-1.1.4-6.fc20.src.rpm
=> libXt-devel-1.1.4-6.fc20.i686 in fedora-development-i386
  File conflict with: libXt-1.1.4-6.fc20.i686
     /usr/share/doc/libXt/CH01.xml
     /usr/share/doc/libXt/CH02.xml
     /usr/share/doc/libXt/CH03.xml
     /usr/share/doc/libXt/CH04.xml
     /usr/share/doc/libXt/CH05.xml
     /usr/share/doc/libXt/CH06.xml
     /usr/share/doc/libXt/CH07.xml
     /usr/share/doc/libXt/CH08.xml
     /usr/share/doc/libXt/CH09.xml
     /usr/share/doc/libXt/CH10.xml
     /usr/share/doc/libXt/CH11.xml
     /usr/share/doc/libXt/CH12.xml
     /usr/share/doc/libXt/CH13.xml
     /usr/share/doc/libXt/COPYING
     /usr/share/doc/libXt/acknowledgement.xml
     /usr/share/doc/libXt/appA.xml
     /usr/share/doc/libXt/appB.xml
     /usr/share/doc/libXt/appC.xml
     /usr/share/doc/libXt/appD.xml
     /usr/share/doc/libXt/appE.xml
     /usr/share/doc/libXt/appF.xml
     /usr/share/doc/libXt/intrinsics.xml
     /usr/share/doc/libXt/preface.xml

=> libXt-1.1.4-6.fc20.src.rpm
=> libXt-1.1.4-6.fc20.i686 in fedora-development-i386
  File conflict with: libXt-devel-1.1.4-6.fc20.i686
     /usr/share/doc/libXt/CH01.xml
     /usr/share/doc/libXt/CH02.xml
     /usr/share/doc/libXt/CH03.xml
     /usr/share/doc/libXt/CH04.xml
     /usr/share/doc/libXt/CH05.xml
     /usr/share/doc/libXt/CH06.xml
     /usr/share/doc/libXt/CH07.xml
     /usr/share/doc/libXt/CH08.xml
     /usr/share/doc/libXt/CH09.xml
     /usr/share/doc/libXt/CH10.xml
     /usr/share/doc/libXt/CH11.xml
     /usr/share/doc/libXt/CH12.xml
     /usr/share/doc/libXt/CH13.xml
     /usr/share/doc/libXt/COPYING
     /usr/share/doc/libXt/acknowledgement.xml
     /usr/share/doc/libXt/appA.xml
     /usr/share/doc/libXt/appB.xml
     /usr/share/doc/libXt/appC.xml
     /usr/share/doc/libXt/appD.xml
     /usr/share/doc/libXt/appE.xml
     /usr/share/doc/libXt/appF.xml
     /usr/share/doc/libXt/intrinsics.xml
     /usr/share/doc/libXt/preface.xml
Comment 1 Michael Schwendt 2013-12-14 07:01:38 EST
Fixed in Rawhide.

The %exclude that had been present in git didn't work, since it cannot exclude exactly the entire directory that %doc uses as well.

Note You need to log in before you can comment on or make changes to this bug.