Bug 1001249 - aunit : duplicate documentation files / potentially conflicting
aunit : duplicate documentation files / potentially conflicting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aunit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-26 15:55 EDT by Michael Schwendt
Modified: 2014-06-18 03:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 02:50:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-26 15:55:36 EDT
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> aunit-2012-4.fc20.src.rpm
=> aunit-devel-2012-4.fc20.i686 in fedora-development-i386
  File conflict with: aunit-2012-4.fc20.i686
     /usr/share/doc/aunit/COPYING3
     /usr/share/doc/aunit/README
     /usr/share/doc/aunit/aunit.html
     /usr/share/doc/aunit/aunit.info
     /usr/share/doc/aunit/aunit.pdf
     /usr/share/doc/aunit/aunit.txt

=> aunit-2012-4.fc20.src.rpm
=> aunit-2012-4.fc20.i686 in fedora-development-i386
  File conflict with: aunit-devel-2012-4.fc20.i686
     /usr/share/doc/aunit/COPYING3
     /usr/share/doc/aunit/README
     /usr/share/doc/aunit/aunit.html
     /usr/share/doc/aunit/aunit.info
     /usr/share/doc/aunit/aunit.pdf
     /usr/share/doc/aunit/aunit.txt
Comment 2 Michael Schwendt 2013-09-03 16:49:02 EDT
* Didn't fix it at all.
* Introduced an odd /usr/share/doc/aunit/__doc directory.
* No %changelog entry.
Comment 3 Pavel Zhukov 2013-09-04 03:26:41 EDT
(In reply to Michael Schwendt from comment #2)
> * Didn't fix it at all.
Fixed
rpm -qpl aunit-devel-2012-7.fc21.x86_64.rpm | grep doc 
/usr/share/doc/aunit-devel
/usr/share/doc/aunit-devel/COPYING3
/usr/share/doc/aunit-devel/README
> * Introduced an odd /usr/share/doc/aunit/__doc directory.
Fixed
> * No %changelog entry.
Added
Comment 4 Michael Schwendt 2013-09-04 04:02:23 EDT
No files are duplicated anymore, but are they placed correctly?

* Now the base package contains the .html/.info/.pdf/.txt developer docs, and the -devel package the license COPYING and README.

* The license file belongs into the base package (and the -devel package depends on that one):
https://fedoraproject.org/wiki/Packaging:LicensingGuidelines#Subpackage_Licensing

* "License" tag claims "GPLv2+", but file COPYING is GPLv3, and source files contain a GPLv3 "or later" preamble.
https://fedoraproject.org/wiki/Packaging:LicensingGuidelines#.22or_later_version.22_licenses

* The README refers to the docs, which are in a different package.

* There's an empty /usr/share/aunit and /usr/share/aunit/examples directory.

* %defattr(...) is superfluous even for RHEL5.

[...]

# repoquery --whatrequires aunit
aunit-devel-0:2012-4.fc20.i686
aunit-devel-0:2012-4.fc20.x86_64

I don't reopen the ticket, because the issues are unrelated to the original issue.

Note You need to log in before you can comment on or make changes to this bug.