Bug 1001258 - dotconf : duplicate documentation files / potentially conflicting
dotconf : duplicate documentation files / potentially conflicting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dotconf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-26 15:56 EDT by Michael Schwendt
Modified: 2013-12-15 10:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 10:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-26 15:56:53 EDT
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> dotconf-1.3-7.fc20.src.rpm
=> dotconf-1.3-7.fc20.i686 in fedora-development-i386
  File conflict with: dotconf-devel-1.3-7.fc20.i686
     /usr/share/doc/dotconf/AUTHORS
     /usr/share/doc/dotconf/COPYING
     /usr/share/doc/dotconf/README

=> dotconf-1.3-7.fc20.src.rpm
=> dotconf-devel-1.3-7.fc20.i686 in fedora-development-i386
  File conflict with: dotconf-1.3-7.fc20.i686
     /usr/share/doc/dotconf/AUTHORS
     /usr/share/doc/dotconf/COPYING
     /usr/share/doc/dotconf/README
Comment 1 Michael Schwendt 2013-12-15 10:52:16 EST
Fixed in Rawhide, leaving F-20 up to maintainers.

Note You need to log in before you can comment on or make changes to this bug.