Bug 1001268 - ocaml-mlgmpidl : duplicate documentation files / potentially conflicting
ocaml-mlgmpidl : duplicate documentation files / potentially conflicting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ocaml-mlgmpidl (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Dunn
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-26 15:58 EDT by Michael Schwendt
Modified: 2017-04-02 16:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: ocaml-mlgmpidl-1.2.1-0.21.20150921.fc26 ocaml-mlgmpidl-1.2.1-0.21.20150921.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-01 13:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed spec changes/fixes (1.53 KB, patch)
2013-12-15 11:47 EST, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2013-08-26 15:58:05 EDT
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> ocaml-mlgmpidl-1.2.1-0.4.20120830.fc20.src.rpm
=> ocaml-mlgmpidl-1.2.1-0.4.20120830.fc20.i686 in fedora-development-i386
  File conflict with: ocaml-mlgmpidl-doc-1.2.1-0.4.20120830.fc20.i686
     /usr/share/doc/ocaml-mlgmpidl/COPYING
     /usr/share/doc/ocaml-mlgmpidl/README
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpfrf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpq.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpqf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpzf.html
     /usr/share/doc/ocaml-mlgmpidl/html/index.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_attributes.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_class_types.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_classes.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_exceptions.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_methods.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_module_types.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_modules.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_types.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_values.html
     /usr/share/doc/ocaml-mlgmpidl/html/style.css
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpfrf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpq.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpqf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpzf.html
     /usr/share/doc/ocaml-mlgmpidl/mlgmpidl.pdf

=> ocaml-mlgmpidl-1.2.1-0.4.20120830.fc20.src.rpm
=> ocaml-mlgmpidl-doc-1.2.1-0.4.20120830.fc20.i686 in fedora-development-i386
  File conflict with: ocaml-mlgmpidl-1.2.1-0.4.20120830.fc20.i686
     /usr/share/doc/ocaml-mlgmpidl/COPYING
     /usr/share/doc/ocaml-mlgmpidl/README
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/Gmp_random.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpfrf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpq.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpqf.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/Mpzf.html
     /usr/share/doc/ocaml-mlgmpidl/html/index.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_attributes.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_class_types.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_classes.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_exceptions.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_methods.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_module_types.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_modules.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_types.html
     /usr/share/doc/ocaml-mlgmpidl/html/index_values.html
     /usr/share/doc/ocaml-mlgmpidl/html/style.css
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Gmp_random.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpfr.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpfrf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpq.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpqf.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpz.html
     /usr/share/doc/ocaml-mlgmpidl/html/type_Mpzf.html
     /usr/share/doc/ocaml-mlgmpidl/mlgmpidl.pdf
Comment 1 Michael Schwendt 2013-12-15 11:47:14 EST
Created attachment 836980 [details]
proposed spec changes/fixes

This would be one way to fix it plus a few other fixes.

Please consider making the -doc package "noarch", or move the docs into the base package with a proper Obsoletes/Provides pair (since the -doc rpm is just 170KB in size).
Comment 2 Jaroslav Reznik 2015-03-03 10:00:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 3 Ville Skyttä 2015-10-18 03:47:21 EDT
Seems to be fixed in ocaml-mlgmpidl-1.2.1-0.17.20150204.fc24. Quickly peeking at the commits doesn't reveal exactly why it would be fixed when 0.16 still has the issue, so I'll leave closing this to Michael if you're satisfied with this.
Comment 4 Ville Skyttä 2015-10-18 03:50:07 EDT
(In reply to Ville Skyttä from comment #3)
> Quickly
> peeking at the commits doesn't reveal exactly why it would be fixed when
> 0.16 still has the issue

Ah, maybe it's this:

http://rpm.org/wiki/Releases/4.13.0
- Don't include not explicitly listed files from doc dir into package (#728959)
Comment 5 Jan Kurik 2016-02-24 08:13:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Fedora Update System 2017-03-25 20:40:29 EDT
apron-0.9.11-6.1097.svn20160801.fc26, flocq-2.5.2-6.fc26, frama-c-1.14-1.fc26, gappalib-coq-1.3.2-4.fc26, ocaml-mlgmpidl-1.2.1-0.21.20150921.fc26, why-2.38-1.fc26, why3-0.87.3-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7be55a4bd6
Comment 7 Fedora Update System 2017-03-25 22:39:34 EDT
apron-0.9.11-6.1097.svn20160801.fc25, frama-c-1.14-1.fc25, ocaml-mlgmpidl-1.2.1-0.21.20150921.fc25, why-2.38-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-237df63a79
Comment 8 Fedora Update System 2017-04-01 13:31:57 EDT
apron-0.9.11-6.1097.svn20160801.fc26, flocq-2.5.2-6.fc26, frama-c-1.14-1.fc26, gappalib-coq-1.3.2-4.fc26, ocaml-mlgmpidl-1.2.1-0.21.20150921.fc26, why-2.38-1.fc26, why3-0.87.3-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2017-04-02 16:53:31 EDT
apron-0.9.11-6.1097.svn20160801.fc25, frama-c-1.14-1.fc25, ocaml-mlgmpidl-1.2.1-0.21.20150921.fc25, why-2.38-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.