Bug 1001290 - geda-gaf : duplicate documentation files / potentially conflicting
geda-gaf : duplicate documentation files / potentially conflicting
Status: CLOSED DUPLICATE of bug 1001242
Product: Fedora
Classification: Fedora
Component: geda-gaf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-26 16:27 EDT by Michael Schwendt
Modified: 2013-08-26 16:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 16:44:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-26 16:27:13 EDT
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> geda-gaf-1.8.1-4.fc20.src.rpm
=> 1:geda-gsymcheck-1.8.1-4.fc20.i686 in fedora-development-i386
  File conflict with: 1:geda-gaf-1.8.1-4.fc20.i686
     /usr/share/doc/geda-gaf/gsymcheck/tests/buses.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/buses.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections1.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections1.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections2.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections2.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections3.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections3.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/correct.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/correct.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_net.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_net.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_correct.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_correct.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_incorrect.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_incorrect.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef1.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef1.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef2.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef2.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef3.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef3.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef4.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef4.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/labelinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/labelinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/lots_of_errors.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/lots_of_errors.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/many_slotdefs.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/many_slotdefs.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/misplaced_attributes.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/misplaced_attributes.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_device.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_device.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_footprint.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_footprint.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_numslots.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_numslots.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinlabel.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinlabel.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_slotdef.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_slotdef.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_footprint.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_footprint.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinlabel.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinlabel.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pintype.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pintype.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_refdes.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_refdes.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/nameinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/nameinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/nets.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/nets.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/noslots.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/noslots.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/old_symbol.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/old_symbol.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldpins.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldpins.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldslot.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldslot.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/pin_offgrid.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/pin_offgrid.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/pintypes.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/pintypes.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/runtest.sh
     /usr/share/doc/geda-gaf/gsymcheck/tests/text_errors.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/text_errors.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/typeinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/typeinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/urefinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/urefinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slotnum.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slotnum.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slots.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slots.sym

=> geda-gaf-1.8.1-4.fc20.src.rpm
=> 1:geda-gaf-1.8.1-4.fc20.i686 in fedora-development-i386
  File conflict with: 1:geda-gsymcheck-1.8.1-4.fc20.i686
     /usr/share/doc/geda-gaf/gsymcheck/tests/buses.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/buses.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections1.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections1.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections2.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections2.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections3.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/connections3.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/correct.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/correct.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_net.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_net.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/duplicate_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_correct.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_correct.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_incorrect.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/graphical_incorrect.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef1.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef1.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef2.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef2.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef3.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef3.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef4.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/invalid_slotdef4.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/labelinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/labelinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/lots_of_errors.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/lots_of_errors.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/many_slotdefs.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/many_slotdefs.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/misplaced_attributes.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/misplaced_attributes.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_device.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_device.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_footprint.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_footprint.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_numslots.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_numslots.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinlabel.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinlabel.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_slotdef.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/missing_slotdef.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_footprint.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_footprint.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinlabel.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinlabel.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pintype.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_pintype.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_refdes.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/multiple_refdes.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/nameinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/nameinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/nets.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/nets.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/noslots.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/noslots.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/old_symbol.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/old_symbol.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldpins.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldpins.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldslot.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/oldslot.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/pin_offgrid.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/pin_offgrid.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/pintypes.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/pintypes.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/runtest.sh
     /usr/share/doc/geda-gaf/gsymcheck/tests/text_errors.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/text_errors.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/typeinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/typeinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/urefinside.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/urefinside.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinnumber.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinnumber.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinseq.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_pinseq.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slotnum.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slotnum.sym
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slots.output
     /usr/share/doc/geda-gaf/gsymcheck/tests/zero_slots.sym
Comment 1 Michael Schwendt 2013-08-26 16:44:45 EDT

*** This bug has been marked as a duplicate of bug 1001242 ***

Note You need to log in before you can comment on or make changes to this bug.