Bug 1001304 - Remove obsolete ControlGroup option from beah service file
Remove obsolete ControlGroup option from beah service file
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.14.4
: ---
Assigned To: Amit Saha
tools-bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 16:54 EDT by Bill Peck
Modified: 2015-07-26 18:15 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 00:09:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2013-08-26 16:54:50 EDT
Description of problem:
beah-srv.service file has ControlGroup in the service file which systemd does not support any more.

Version-Release number of selected component (if applicable):
0.6.45-1.fc17

How reproducible:
Everytime on Fedora20 or Rawhide

Additional info:
Please see the following article for background
https://lwn.net/Articles/555922/
Comment 2 Nick Coghlan 2013-08-26 23:08:28 EDT
This sounds like it needs to be filed as a bug against systemd, not against Beaker. Silently breaking every unit file that contains a CGroup definition instead of emitting a warning that the definition is being ignored is extraordinarily user hostile.
Comment 3 Nick Coghlan 2013-08-26 23:41:23 EDT
Then again...

Bill, Amit tried starting beah on the next-to-latest rawhide systemd (systemd-206-6.fc20.x86_64) and couldn't reproduce the report failure. It appeared to start fine for him:

=========================================
# systemctl status beah-srv
beah-srv.service - The Beaker Harness server.
   Loaded: loaded (/usr/lib/systemd/system/beah-srv.service; disabled)
   Active: active (running) since Mon 2013-08-26 21:21:25 MDT; 7s ago
 Main PID: 7373 (beah-srv)
   CGroup: /system.slice/beah-srv.service
           └─7373 /usr/bin/python /usr/bin/beah-srv
 
Aug 26 21:21:25 localhost.localdomain systemd[1]: Starting The Beaker Harness server....
Aug 26 21:21:25 localhost.localdomain systemd[1]: Started The Beaker Harness server..
[root@localhost yum.repos.d]#
=========================================

Starting it as shown also created /sys/fs/cgroup/systemd/system.slice/beah-srv.service/ as expected.

What are the failure symptoms you're seeing?

Independent of any direct impact on beah, this systemd change may have flow on effects to the use cases that led to the ControlGroup setting being added in bug 773259 in the first place.
Comment 5 Bill Peck 2013-08-27 09:17:52 EDT
Hi Nick,

It looks like there is just a significant delay before systemd tries to launch beah.  I am doing this in my home lab so maybe I don't have time services configured properly and chrony is timing out?

In any event, this is what I see in the journal on a fresh install of Fedora-20-20130827 fedora x86_64

Aug 27 13:00:17 localhost.localdomain systemd[1]: [/usr/lib/systemd/system/beah-srv.service:4] Failed to add dependency on beah-beaker-backend, ignoring: Invalid argument
Aug 27 13:00:17 localhost.localdomain systemd[1]: [/usr/lib/systemd/system/beah-srv.service:4] Failed to add dependency on beah-fwd-backend, ignoring: Invalid argument
Aug 27 13:00:17 localhost.localdomain systemd[1]: [/usr/lib/systemd/system/beah-srv.service:9] Unknown lvalue 'ControlGroup' in section 'Service'

So I don't think this is a blocker but I do think we will need to remove this option from the services file eventually.

Thanks
Comment 6 Amit Saha 2013-11-20 00:33:52 EST
http://gerrit.beaker-project.org/#/c/2515/
Comment 7 Amit Saha 2013-11-26 03:12:18 EST
Verification tip:

Note that this affects RHEL 7 and Fedora systems only.

Messages such as "[/usr/lib/systemd/system/beah-srv.service:9] Unknown lvalue 'ControlGroup' in section 'Service'" should not be present for RHEL 7 in /var/log/messages.

Note You need to log in before you can comment on or make changes to this bug.