Bug 1001306 - virt-who creates hypervisor instead of guest
virt-who creates hypervisor instead of guest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Radek Novacek
Katello QA List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-26 16:59 EDT by robert.redhat
Modified: 2016-11-30 19:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 14:03:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm.log (38.69 KB, text/plain)
2013-08-27 10:10 EDT, robert.redhat
no flags Details
rhsm with virt-who debug set (8.96 KB, text/plain)
2013-08-27 13:51 EDT, robert.redhat
no flags Details
rhsm with update after bugfix (3.47 KB, text/plain)
2013-08-28 15:38 EDT, robert.redhat
no flags Details

  None (edit)
Description robert.redhat 2013-08-26 16:59:11 EDT
While attempting to use a subscription (Red Hat Enterprise Linux Server, Premium (1-2 sockets) (Unlimited guests)) in an ESXi environment, it seems virt-who is creating hypervisor accounts instead of the guests in katello.

vsphere.py has applied the changes from https://git.fedorahosted.org/cgit/virt-who.git/commit/?id=543ba2d983c8588b568664237488d16401253b58

virt-who is running on the katello server which is registered to itself using subscription-manager.
Comment 1 Radek Novacek 2013-08-27 02:58:11 EDT
virt-who doesn't create any accounts, it merely reports association between virtualization hosts and their guests.
Comment 2 robert.redhat 2013-08-27 08:24:23 EDT
Perhaps you can answer something for me about how I should be using virt-who, then. It has obviously picked up several hosts, but when I register another server to Katello it doesn't find the host that the server is on. It recognizes that the system is a guest, but can't find the host.

Is this because I'm using ESXi?

Any direction would be greatly appreciated.
Comment 3 Radek Novacek 2013-08-27 08:40:49 EDT
It might be bug in virt-who. Could you check logs in /var/lib/rhsm.log if the host-guest association is obtained correctly (or attach the log file here or send it to me to rnovacek (at) redhat (dot) com). You might need to set VIRTWHO_DEBUG=1 in /etc/sysconfig/virt-who.
Comment 4 robert.redhat 2013-08-27 10:10:55 EDT
Created attachment 790992 [details]
rhsm.log

This log starts at the point where I was able to get virt-who to connect to vcenter.
Comment 5 Radek Novacek 2013-08-27 10:37:10 EDT
The log is quite silent about virt-who, could you enable the debug mode as I suggested in comment #3.
Comment 6 robert.redhat 2013-08-27 13:51:52 EDT
Created attachment 791132 [details]
rhsm with virt-who debug set
Comment 7 Radek Novacek 2013-08-28 10:38:33 EDT
It seems that you're facing bug 1002058. When there is a lot of virtual guests (more than 100), virt-who fails to report their UUIDs correctly.
Comment 8 robert.redhat 2013-08-28 15:37:01 EDT
I installed the latest version from git repo (as of about 3PM EST), however I now get errors in rhsm.log (attached)
Comment 9 robert.redhat 2013-08-28 15:38:00 EDT
Created attachment 791520 [details]
rhsm with update after bugfix
Comment 10 robert.redhat 2013-09-05 14:02:30 EDT
This can be closed, by the way. The version of virt-who from 2013-08-30 has solved this.
Comment 11 Bryan Kearney 2013-09-05 14:03:55 EDT
See comment 9.

Note You need to log in before you can comment on or make changes to this bug.