Bug 1001316 - Location of yum is incorrect in /etc/sudoers
Location of yum is incorrect in /etc/sudoers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
19
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 17:13 EDT by Bryan Mason
Modified: 2013-08-26 17:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 17:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Mason 2013-08-26 17:13:20 EDT
Description of problem:

    /etc/sudoers contains the line:

    # Cmnd_Alias SOFTWARE = /bin/rpm, /usr/bin/up2date, /usr/bin/yum

    However, in Fedora 19, yum is located in /bin

Version-Release number of selected component (if applicable):

    sudo-1.8.6p7-1.fc19.x86_64
 
How reproducible:

    100%

Steps to Reproduce:

    1.  Add a line in sudoers to allow a user to run commands in the
        SOFTWARE alias.
    2. Log in as that user and try to run "sudo yum install ..."

Actual results:

    Sorry, user <user> is not allowed to execute '/bin/yum -y install ...'
    as root on computer.example.com

Expected results:

    The unprivileged user should be allowed to run yum as root using
    sudo.

Additional info:

    It looks like yum is now located in /bin/yum.
Comment 1 Bryan Mason 2013-08-26 17:16:58 EDT
Never mind.  I thought that was causing my inability to run yum, but it was something else.

Note You need to log in before you can comment on or make changes to this bug.