Bug 1001324 - fingerprint activity led is never turned on [NEEDINFO]
fingerprint activity led is never turned on
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 17:55 EDT by Ferry Huberts
Modified: 2014-03-10 10:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 10:46:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jforbes: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2013-08-26 17:55:32 EDT
Description of problem:
Since the latest kernel update the 'active' LED of the fingerprint scanner on my Lenovo W520 doesn't turn on anymore when it's active.


Version-Release number of selected component (if applicable):
kernel 3.10.9-200.fc19.x86_64 

How reproducible:
always


Additional info:

lsusb
Bus 001 Device 004: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Comment 1 Josh Boyer 2013-08-27 09:39:48 EDT
Did this work in previous kernels?  If so, which was the last working version and first broken version?
Comment 2 Ferry Huberts 2013-08-27 10:48:42 EDT
All kernels I have installed exhibit this, so maybe it's a different update. You make me doubt... ;-)

I only recently noticed it, like the past week or so.
But then again, I never pay much attention to the led.

kernel-3.10.6-200.fc19.x86_64
kernel-3.10.7-200.fc19.x86_64
kernel-3.10.9-200.fc19.x86_64


I booted windblows to make sure that the led is not broken, and it's working ok :-)
Comment 3 Ferry Huberts 2013-08-27 11:13:29 EDT
Ok, this is definitely weird.
I booted F19 64 live and there it worked ok.
Then booted into my most recent kernel on the hard disc and now it works ok again. The led turns on on login and when doing a sudo, as it should.

I'd say there's something fishy :-)
Comment 4 Ferry Huberts 2013-08-29 01:50:50 EDT
I just saw it go wrong.
Coming out of suspend I saw the LED turn on and then off, while I could still use the fingerprint scanner to log in.
Comment 5 Ferry Huberts 2013-08-31 11:33:27 EDT
And then a few suspend/resume cycles later and it works again.
strange
Comment 6 Justin M. Forbes 2014-01-03 17:12:28 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 7 Justin M. Forbes 2014-03-10 10:46:10 EDT
*********** MASS BUG UPDATE **************

This bug has been in a needinfo state for more than 1 month and is being closed with insufficient data due to inactivity. If this is still an issue with Fedora 19, please feel free to reopen the bug and provide the additional information requested.

Note You need to log in before you can comment on or make changes to this bug.