Bug 1001328 - Yum update error - "ERROR with transaction check vs depsolve:"
Yum update error - "ERROR with transaction check vs depsolve:"
Status: CLOSED DUPLICATE of bug 912012
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 18:09 EDT by norbert.murzsa
Modified: 2013-08-27 17:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 02:46:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description norbert.murzsa 2013-08-26 18:09:58 EDT
Description of problem:
Error during the "yum update" process:
ERROR with transaction check vs depsolve:
httpd-mmn = 20051115-x86-32 is needed by (installed) mod_python-3.3.1-18.fc17.i686

Version-Release number of selected component (if applicable):
Fedora: release 18 (Spherical Cow)
Kernel: 3.10.4-100.fc18.i686.PAE

How reproducible:
Simply run "yum update"

Steps to Reproduce:
1. yum update


Actual results:
Transaction Summary
=========================================================================================================================================================================================
Install    1 Package  (+3 Dependent packages)
Upgrade  126 Packages
Remove     1 Package

Total size: 187 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
httpd-mmn = 20051115-x86-32 is needed by (installed) mod_python-3.3.1-18.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 10 pre-existing rpmdb problem(s), 'yum check' output follows:
libopenvrml-0.18.9-3.fc17.i686 has missing requires of libboost_filesystem-mt.so.1.48.0
libopenvrml-0.18.9-3.fc17.i686 has missing requires of libboost_system-mt.so.1.48.0
libopenvrml-0.18.9-3.fc17.i686 has missing requires of libboost_thread-mt.so.1.48.0
libopenvrml-gl-0.18.9-3.fc17.i686 has missing requires of libboost_filesystem-mt.so.1.48.0
libopenvrml-gl-0.18.9-3.fc17.i686 has missing requires of libboost_system-mt.so.1.48.0
libopenvrml-gl-0.18.9-3.fc17.i686 has missing requires of libboost_thread-mt.so.1.48.0
mod_python-3.3.1-18.fc17.i686 has missing requires of httpd-mmn = ('0', '20051115', 'x86-32')
openvrml-xembed-0.18.9-3.fc17.i686 has missing requires of libboost_filesystem-mt.so.1.48.0
openvrml-xembed-0.18.9-3.fc17.i686 has missing requires of libboost_system-mt.so.1.48.0
openvrml-xembed-0.18.9-3.fc17.i686 has missing requires of libboost_thread-mt.so.1.48.0
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-08-27.09-59.Sr3TZv.yumtx


Expected results:
Successful update with no error message

Additional info:
Comment 1 Jan Zeleny 2013-08-27 02:46:38 EDT
There is a bunch of problems on your system, none of which points to a bug in yum.

mod_python: duplicate of bug 912012

10 other pre-existing rpmdb problems: looks like a fedup issue, probably solved in newer versions. To solve these pre-existing problems, you either need to manually install missing requirements or uninstall the packages depending on them.

HTH

*** This bug has been marked as a duplicate of bug 912012 ***
Comment 2 norbert.murzsa 2013-08-27 06:06:07 EDT
Hi Jan,

I upgraded to v18 some months ago so this couldn't cause by a recent upgrade.
I haven't been experiencing any issue with the updates since then but the today's error.
I updated the system manually. but the remaining httpd package and its dependencies are still presenting the same error so httpd can't be updated until this issue has fixed.

Kind Regards

Norbert


[root@lzoom ~]# yum -y update httpd
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * fedora: ucmirror.canterbury.ac.nz
 * rpmfusion-free: ucmirror.canterbury.ac.nz
 * rpmfusion-free-updates: ucmirror.canterbury.ac.nz
 * updates: ucmirror.canterbury.ac.nz
Resolving Dependencies
--> Running transaction check
---> Package httpd.i686 0:2.4.4-3.fc18 will be updated
--> Processing Dependency: httpd = 2.4.4-3.fc18 for package: httpd-manual-2.4.4-3.fc18.noarch
--> Processing Dependency: httpd = 2.4.4-3.fc18 for package: 1:mod_ssl-2.4.4-3.fc18.i686
---> Package httpd.i686 0:2.4.6-2.fc18 will be an update
--> Processing Dependency: httpd-tools = 2.4.6-2.fc18 for package: httpd-2.4.6-2.fc18.i686
--> Running transaction check
---> Package httpd-manual.noarch 0:2.4.4-3.fc18 will be updated
---> Package httpd-manual.noarch 0:2.4.6-2.fc18 will be an update
---> Package httpd-tools.i686 0:2.4.4-3.fc18 will be updated
---> Package httpd-tools.i686 0:2.4.6-2.fc18 will be an update
---> Package mod_ssl.i686 1:2.4.4-3.fc18 will be updated
---> Package mod_ssl.i686 1:2.4.6-2.fc18 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================================================================================
 Package                                       Arch                                    Version                                          Repository                                Size
=======================================================================================================================================================================================
Updating:
 httpd                                         i686                                    2.4.6-2.fc18                                     updates                                  1.2 M
Updating for dependencies:
 httpd-manual                                  noarch                                  2.4.6-2.fc18                                     updates                                  1.3 M
 httpd-tools                                   i686                                    2.4.6-2.fc18                                     updates                                   76 k
 mod_ssl                                       i686                                    1:2.4.6-2.fc18                                   updates                                   96 k

Transaction Summary
=======================================================================================================================================================================================
Upgrade  1 Package (+3 Dependent packages)

Total size: 2.6 M
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
httpd-mmn = 20051115-x86-32 is needed by (installed) mod_python-3.3.1-18.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 10 pre-existing rpmdb problem(s), 'yum check' output follows:
libopenvrml-0.18.9-3.fc17.i686 has missing requires of libboost_filesystem-mt.so.1.48.0
libopenvrml-0.18.9-3.fc17.i686 has missing requires of libboost_system-mt.so.1.48.0
libopenvrml-0.18.9-3.fc17.i686 has missing requires of libboost_thread-mt.so.1.48.0
libopenvrml-gl-0.18.9-3.fc17.i686 has missing requires of libboost_filesystem-mt.so.1.48.0
libopenvrml-gl-0.18.9-3.fc17.i686 has missing requires of libboost_system-mt.so.1.48.0
libopenvrml-gl-0.18.9-3.fc17.i686 has missing requires of libboost_thread-mt.so.1.48.0
mod_python-3.3.1-18.fc17.i686 has missing requires of httpd-mmn = ('0', '20051115', 'x86-32')
openvrml-xembed-0.18.9-3.fc17.i686 has missing requires of libboost_filesystem-mt.so.1.48.0
openvrml-xembed-0.18.9-3.fc17.i686 has missing requires of libboost_system-mt.so.1.48.0
openvrml-xembed-0.18.9-3.fc17.i686 has missing requires of libboost_thread-mt.so.1.48.0
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-08-27.22-02.IZppBC.yumtx
[root@lzoom ~]#
Comment 3 Jan Zeleny 2013-08-27 06:19:41 EDT
Ok, but the rest of my previous comment still stands. You have to uninstall mod_python (it is discontinued in F18+), then the upgrade might work. However I'd still recommend solving those problems in rpmdb (as described above), they indicate broken state of a part of your system.
Comment 4 norbert.murzsa 2013-08-27 06:46:56 EDT
Hi Jan,

I removed the mod_python as you suggested and also rebuilt the rpmdb and cleared the yum.
Problem has solved now. No further package to install after the last "yum update" and no error message either.

* * *
[root@lzoom ~]# rpm -e mod_python
[root@lzoom ~]# rm -f /var/lib/rpm/__db* && rpm --rebuilddb
[root@lzoom ~]# yum clean metadata && yum clean dbcache && yum clean rpmdb
* * *

Your help was much appreciated.

Kind Regards

Norbert
Comment 5 Jan Zeleny 2013-08-27 07:11:14 EDT
I'm glad to head that however rpm --rebuilddb was not what I was referring to when talking about rpmdb cleanup. Run yum check to see if you have any broken deps on your system (previous messages suggested that you do). The cleanup of those broken deps is what I was originally talking about.
Comment 6 norbert.murzsa 2013-08-27 17:38:45 EDT
Hi Jan,

I found some v17 packages that seem deprecated now and weren't removed during the upgrade to v18.

libboost_thread
libboost_thread-mt
openvrml-xembed
openvrml-mozilla-plugin-0.18.9-3.fc17.i686
libopenvrml-xembed
openvrml-xembed
libopenvrml-gl
libopenvrml

After the removal of the packages above command "yum check" gives no error back.
* * *
[root@lzoom ~]# yum check
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, security
check all
[root@lzoom ~]# 
* * *

Thanks

Kind Regards

Norbert

Note You need to log in before you can comment on or make changes to this bug.