Bug 1001394 - Fedora compilation should not be released under GPLv2
Fedora compilation should not be released under GPLv2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 20:44 EDT by Richard Fontana
Modified: 2014-08-25 20:22 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1096434 (view as bug list)
Environment:
Last Closed: 2014-02-26 06:53:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Fontana 2013-08-26 20:44:02 EDT
The file modules/eula.py causes the display of the following:

"Fedora is a compilation of software packages, each under its own license.  The 
compilation is made available under the GNU General Public License version 
2.  There are no restrictions on using, copying, or modifying this code.  
However, there are restrictions and obligations that apply to the 
redistribution of the code, either in its original or a modified form.  
Among other things, those restrictions/obligations pertain to the 
licensing of the redistribution, trademark rights, and export control."

It is true that a given Fedora release is a compilation (in the copyright sense) of software packages. However, it is either nonsensical or pointless to suggest that the license of this compilation is GPLv2. A Fedora release is clearly "mere aggregation" in the sense meant in GPLv2 section 2. GPLv2 is not suitable for licensing of "mere aggregation". It is not clear how to map the terms of GPLv2 to the *compilation*, the aggregation-in-the-abstract, that is a Fedora release, as opposed to the individual packages, which are already licensed in whatever way they are licensed (with GPLv2 no doubt being the majority license). The user might be misled into thinking that the contents of a release are being somehow substantively relicensed under GPLv2, which is obviously not possible, desirable or intended.

I am not sure if it is particularly important to explicitly specify the license of the Fedora *compilation* at all. However, it seems to me that if anything the license of the compilation should be as non-restrictive as possible. The displayed message suggests that there are restrictions/obligations on the "licensing of the redistribution", which in this context seems to mean that a redistribution must be licensed under GPLv2 as to the compilation. But either that achieves nothing, or places unintended restrictions on uses of Fedora that are meant to be permitted. The majority of GPL'd packages remain under that license in an unmodified redistribution, while a modified redistribution might well include proprietary or GPL-incompatible free software packages not contained in Fedora upstream.
Comment 1 Richard Fontana 2013-08-26 20:49:16 EDT
Blocking FE-Legal.
Comment 2 Vratislav Podzimek 2014-02-11 10:57:50 EST
(In reply to Richard Fontana from comment #0)
> The file modules/eula.py causes the display of the following:
What modules/eula.py file are you writing about? Can you please provide a full path and, ideally, run 'rpm -qf THAT_PATH' on it so that we know the name of the package owning that file?
Comment 3 Martin Kolman 2014-02-26 06:53:51 EST
Closing for not enough information to do something about it. Please feel free to reopen if you are able to provide it.
Comment 4 Richard Fontana 2014-02-26 08:53:22 EST
Sorry, I haven't figured out where the counterpart information now resides. Once I do I will probably reopen. Thanks!
Comment 5 R P Herrold 2014-03-17 14:37:17 EDT
Per Comment 4, 

In a RHEL environment, the EULA seems to be being sourced from:
           self.eula_path = "/usr/share/doc/redhat-release*/EULA"

by:
   /usr/share/firstboot/modules/eula.py

no idea if this is accurate or not for Fedora or as a general rule, but this may help.  * I would suspect it may vary from renamings 
  as in rehat-config-network -> system-config-network
or such

Note You need to log in before you can comment on or make changes to this bug.