Bug 1001418 - Upgrade from RHS2.0-U5 to U6 results in broken gluster-swift services, it gives 503 for every request
Upgrade from RHS2.0-U5 to U6 results in broken gluster-swift services, it gi...
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: object-storage (Show other bugs)
3.3.2
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Thiago da Silva
: ZStream
Depends On: 1000423
Blocks: 997940
  Show dependency treegraph
 
Reported: 2013-08-26 22:58 EDT by Luis Pabón
Modified: 2016-11-08 17:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1000423
Environment:
Last Closed: 2014-12-14 14:40:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-26 23:02:39 EDT
REVIEW: http://review.gluster.org/5706 (Do not overwrite swift config files on upgrade) posted (#2) for review on release-3.3 by Luis Pabon (lpabon@redhat.com)
Comment 2 Anand Avati 2013-08-27 03:50:16 EDT
REVIEW: http://review.gluster.org/5706 (Do not overwrite swift config files on upgrade) posted (#3) for review on release-3.3 by Vijay Bellur (vbellur@redhat.com)
Comment 3 Anand Avati 2013-08-27 23:40:57 EDT
COMMIT: http://review.gluster.org/5706 committed in release-3.3 by Vijay Bellur (vbellur@redhat.com) 
------
commit 41deb1ec8f7d1091de702947876444dd713fab7f
Author: Luis Pabon <lpabon@redhat.com>
Date:   Mon Aug 26 15:22:14 2013 -0400

    Do not overwrite swift config files on upgrade
    
    We now include the config files as part of the RPM and include
    the directive %config(noreplace) in the RPM specfile for
    upgrades, installations, and removals.
    
    When the system is now upgraded to this fix number, any of the
    config files edited are kept verbatim.  When the system
    is upgraded to the gluster-swift project, their config files
    are saved as ${configfile}.rpmsave since they will need to
    re-inspect the file using the new grizzly settings.
    
    BUG: 1001418
    
    Change-Id: I306501d3148f5f6a1d2ee381a9abd98efccadd00
    Signed-off-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-on: http://review.gluster.org/5706
    Reviewed-by: Peter Portante <pportant@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Niels de Vos 2014-11-27 09:54:32 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.