Bug 1001421 - Anaconda freezes immediately after entering the hub
Anaconda freezes immediately after entering the hub
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 23:20 EDT by Mukundan Ragavan
Modified: 2014-02-21 13:44 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 13:44:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda screen that froze (77.81 KB, image/png)
2013-08-26 23:20 EDT, Mukundan Ragavan
no flags Details
anaconda.log (4.98 KB, text/plain)
2013-08-26 23:20 EDT, Mukundan Ragavan
no flags Details
program.log (4.37 KB, text/plain)
2013-08-26 23:21 EDT, Mukundan Ragavan
no flags Details
storage.log (16.15 KB, text/plain)
2013-08-26 23:21 EDT, Mukundan Ragavan
no flags Details
syslog (71.92 KB, text/plain)
2013-08-26 23:23 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2013-08-26 23:20:18 EDT
Created attachment 790741 [details]
Anaconda screen that froze

Description of problem:

Boot Fedora 20 Alpha TC1 DVD and choose language (English (US) in my case), click next.

Anaconda completely freezes. No option can be selected and the screen does not change for more than 30 minutes (I shutdown the VM after that).

This happens in a VM that I used few minutes ago to install F20 using the same image.

Version-Release number of selected component (if applicable):
Anaconda 20.8-1

How reproducible:
Not always. Happens suddenly.

Actual results:
Anaconda freezes, screenshot attached.

Expected results:
Installer should work.
Comment 1 Mukundan Ragavan 2013-08-26 23:20:50 EDT
Created attachment 790742 [details]
anaconda.log
Comment 2 Mukundan Ragavan 2013-08-26 23:21:35 EDT
Created attachment 790743 [details]
program.log
Comment 3 Mukundan Ragavan 2013-08-26 23:21:58 EDT
Created attachment 790744 [details]
storage.log
Comment 4 Mukundan Ragavan 2013-08-26 23:23:23 EDT
Created attachment 790745 [details]
syslog

I have attached all the logs that I thought would be useful.
Comment 5 David Shea 2013-08-27 08:13:20 EDT
The storage.log indicates that anaconda is running resize2fs to resize a filesystem, and this can take a very long time. What steps did you perform up to this point? Are you using a kickstart file? Did you specify a storage configuration?
Comment 6 Mukundan Ragavan 2013-08-27 08:33:07 EDT
(In reply to David Shea from comment #5)
> The storage.log indicates that anaconda is running resize2fs to resize a
> filesystem, and this can take a very long time. What steps did you perform
> up to this point? 

I chose the language (English US) in the first screen that appears upon booting the DVD and I got this screen.

> Are you using a kickstart file?

No. I am/was trying to install from the DVD using anaconda graphical.

> Did you specify a storage configuration?

No.
Comment 7 Leslie Satenstein 2013-10-19 09:20:21 EDT
I apologize for not creating multiple bug reports for Beta TC5.
1) From TZ selection, Montreal is missing from the list and the map. Has been there from Core days and it is no longer there.  If it was removed because of being in the same Timezone as New York and Toronto (Eastern TZ), then you should also remove one of Toronto or New York.
2) Since Fedora 18, one cannot scroll the city list if one needs to rescroll a second time.  (I filed Bugzilla reports for F18 alpah, F18 Beta, F18, F19 Alpha F19 beta , F19, F20 Alpha, and I will now update that bugzilla report for F20 Beta). Two and a half years of bugzilla reporting and no action to repair.
3) As reported since F18alpa, the keyboard layout is missing a key between the Z and the left shift key. Again, refer to my bugzilla reports and attached print screens.
4) Default hostname in Network Configuration says Fedora19. We are testing Fedora20,  Suggest default hostname as Fedora20.Fedora20
5)Can you put a better description for Design Suite. It essentially reads as  Design Suite is for Designers. Is Design suite for housing, web, or program design?
6)  Wireless Setup. Did the checkbox to show hostname password disappear. A long password (20chars) is next to impossible to enter correctly except after a few attempts to get it right?
7) Thin LVM provisioning on my system boots as far as Waiting for basic system. until the dracut prompt arrives. 
8) I purposely put in a weak password for "root". There is no prompt to request doing a double entry on "done" to accept. After rebooting, I put in the strong root password.  Ditto for normal/Admin user.  Prompt that to confirm password is missing.
9)I believe that Anaconda has some touchups to reposition some fields. My monitor received wrong size information and half the button on the right side of the screen was omitted.

After reboot, Configuring the "add cloud account" came up empty. This add account option with choices was present in the F20 ALPHA version.

The keyboard layout for latam has the wrong character for the alt-GR 2 key.
The @ symbol is appearing instead of the ` .  The key to show < > and  alt-GR |¦
is missing, It too is located between the Z key and the left shift key. Again, refer to bugzilla report for F18, F19 and now F20 Alpha.
  
Please redistribute this report. I will report again after F20 updates are installed.
Comment 8 Leslie Satenstein 2013-10-19 10:11:00 EDT
I am continuing here with problems.
1) After logon, there is no indication the system is ready.

2) The user name in the popdown menu is omitted. I share the pc with wife and three kids, and we each have separate logons.  How can we tell which user is logged on? Did someone change my logon while I went to wash my hands? (In my own home I do not have to lock the screen to go to wash my hands or walk to the kitchen to take a cup of coffee).

3) I am trilingual. I installed by selecting English, but only with the Canada French layout. When I rebooted after Anaconda installation, I could not log into the system because the wrong keyboard is set. I (I did remove English, and inserted Canada French).

4) Keyboard selection says French(France), but actually, it is French from many countries. Some of which use the azerty keyboard, and some that use the pc105 Canadian French keyboard.  Please remove the France word from the initial keyboard selection option.

5) I log out more often than do a poweroff.  Can the button for user include the user name?  Why do I have to go to terminal mode and type the ID command to see which user is logged on.

6)Why should one button be used for poweroff, but it takes one click to select the user popdown menu, a second to click on the name presented name, and a third to mouse click to select "switch user/log out". Is Fedora a single user system and to leave Fedora we poweroff?  Gnome! stop emulating Android and consider the actual user. I am going to stick to Fedora 19 until Fedora20 becomes ergonomically friendly.  
The Video driver puts the screen about 3 characters past the right screen margin. I have to test click past the right margin to see if I can tell who is logged on.
7) While logged in, I did click on the print-screen button, and will evaluate it. It will show the popdown menu, and configure, lock, and poweroff. Why is poweroff button presented again. It should be a logout button at least. 
8) Can designers please think of how to minimize the number of mouse key clicks to initiate an action. I should not have to ask if the Designers only look at real-estate, and not at user friendliness.
Comment 9 Mukundan Ragavan 2013-10-19 11:08:30 EDT
Bugzilla is not a generic discussion forum. I suggest sending your list of complaints to test@ with links to relevant bug reports that you filed. 

Please only add information pertinent to this bug report here.
Comment 10 David Shea 2014-02-21 13:32:15 EST
Does this problem still occur with the F20 release?
Comment 11 Mukundan Ragavan 2014-02-21 13:44:45 EST
I don't think so. I have used F20 now in multiple systems (VM and bare metal) without this issue.

I am not seeing this in rawhide versions either. 

I think we can close this bug now. I am not sure what resolution to choose - currentrelease?

Note You need to log in before you can comment on or make changes to this bug.