Bug 1001428 - [zh_CN][Admin Portal] Translated string '时出错' displayed in the wrong line in the error message box of Data Centers->Storage->Maintenance.
[zh_CN][Admin Portal] Translated string '时出错' displayed in the wrong line in ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
high Severity high
: ---
: 3.3.0
Assigned To: Isaac Rooskov
Yuko Katabami
i18n
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 23:40 EDT by Lijun Li
Modified: 2016-02-10 14:00 EST (History)
13 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:11:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: i18n
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Translated string '时出错' displayed in the wrong line in the error message box. (78.07 KB, image/png)
2013-08-26 23:46 EDT, Lijun Li
no flags Details
screen-shot: Zanata (52.79 KB, image/png)
2013-09-06 10:10 EDT, Einav Cohen
no flags Details
One message is fixed (19.93 KB, image/png)
2013-09-25 02:18 EDT, Yuko Katabami
no flags Details
Fixed_Error while executing action (17.57 KB, image/png)
2013-09-26 22:56 EDT, Lijun Li
no flags Details
zh-CN error message with redundant English words is now fixed. (28.22 KB, image/png)
2013-09-26 23:27 EDT, Yuko Katabami
no flags Details

  None (edit)
Description Lijun Li 2013-08-26 23:40:02 EDT
Description of problem:
[zh_CN][Admin Portal] Translated string '时出错' displayed in the wrong line in the error message box of Data Centers->Storage->Maintenance.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.16.master.el6ev.noarch.rpm
rhevm-webadmin-portal-3.3.0-0.16.master.el6ev.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Login web admin portal.
2. Click on Data Centers -> Storage sub tab.
3. Select a domain which has the active VM and click Maintenance button.


Actual results:
Translated string '时出错' displayed in the wrong line in the error message box of Data Centers->Storage->Maintenance.

Expected results:
It should be displayed in the line of '	执行动作 无法 deactivate Storage'.

Additional info:
Please refer to the attached screen shot for more details.
Comment 1 Lijun Li 2013-08-26 23:46:15 EDT
Created attachment 790747 [details]
Translated string '时出错' displayed in the wrong line in the error message box.
Comment 5 Einav Cohen 2013-09-06 10:10:00 EDT
Created attachment 794777 [details]
screen-shot: Zanata
Comment 6 Einav Cohen 2013-09-06 10:18:35 EDT
there are two messages in the application that contain the string "Error while executing action":

(1) "Error while executing action {0}: {1}"
current zh-CN translation in Zanata: "执行动作 {0} 时出错: {1}"

(2) Error while executing action: {0}
current zh-CN translation in Zanata: "执行动作 {0} 时出错"

so I don't think that the issue is a missing/misplaced parameter, as Allon suggested in Comment #3 - all parameters seem to be in place.

I admit that I am not sure exactly what the problem is.

@Lijun Li - can you please further clarify what the problem is?

[if the problem is a too long string, I assume that you can either utilize your own suggested solution from Comment #2, or utilize Daniel's solution from Comment #4].

in any case, it seems that the problem can be handled in the translation level (i.e. in Zanata).

if you have any questions, comments or concerns, please 'needinfo' me.

thanks.
Comment 7 Lijun Li 2013-09-09 01:53:24 EDT
(In reply to Einav Cohen from comment #6)
> there are two messages in the application that contain the string "Error
> while executing action":
> 
> (1) "Error while executing action {0}: {1}"
> current zh-CN translation in Zanata: "执行动作 {0} 时出错: {1}"
> 
> (2) Error while executing action: {0}
> current zh-CN translation in Zanata: "执行动作 {0} 时出错"
> 
> so I don't think that the issue is a missing/misplaced parameter, as Allon
> suggested in Comment #3 - all parameters seem to be in place.
> 
> I admit that I am not sure exactly what the problem is.
> 
> @Lijun Li - can you please further clarify what the problem is?
> 
> [if the problem is a too long string, I assume that you can either utilize
> your own suggested solution from Comment #2, or utilize Daniel's solution
> from Comment #4].
> 
> in any case, it seems that the problem can be handled in the translation
> level (i.e. in Zanata).
> 
> if you have any questions, comments or concerns, please 'needinfo' me.
> 
> thanks.
The problem is that the string '。时出错' at the end of sentence is not clear to Chinese uer. I checked in Zanata, can zh_CN translated string formart same as ja_JP?


ja_JP: 
Error while executing action {0}: {1}
{0}のアクションを実行中にエラーが発生しました: {1}

Error while executing action: {0}
アクションを実行中にエラーが発生しました: {0}

zh_CN:
Error while executing action {0}: {1}
执行动作 {0} 时出错: {1} --> {0}执行动作时出错: {1}

Error while executing action: {0}
执行动作 {0} 时出错 --> 执行动作时出错: {0} 

Thanks,
Robert
Comment 8 Einav Cohen 2013-09-09 15:29:32 EDT
Thanks for the clarification, Robert.

@Yuko - can you please assign to the relevant zh-CN translator? see Robert's recommendation for the improved translations in Comment #7. 
Also, if indeed intended to be fixed - please "devel_ack+". thanks.
Comment 9 Yuko Katabami 2013-09-09 17:50:54 EDT
(In reply to Einav Cohen from comment #8)
> Thanks for the clarification, Robert.
> 
> @Yuko - can you please assign to the relevant zh-CN translator? see Robert's
> recommendation for the improved translations in Comment #7. 
> Also, if indeed intended to be fixed - please "devel_ack+". thanks.

@Einav - Sure. I will check with our zh-CN translator and report what we are doing here.
Comment 10 Yuko Katabami 2013-09-09 21:23:41 EDT
Robert, our zh-CN translator Simon has fixed his translation in Zanata.
Let me know if it requires any further changes.
Comment 11 Lijun Li 2013-09-11 02:45:36 EDT
(In reply to Yuko Katabami from comment #10)
> Robert, our zh-CN translator Simon has fixed his translation in Zanata.
> Let me know if it requires any further changes.

Thanks Yuko, will verify it in the next build's Web GUI.
Comment 12 Yuko Katabami 2013-09-25 02:18:57 EDT
Created attachment 802573 [details]
One message is fixed
Comment 13 Yuko Katabami 2013-09-25 02:20:30 EDT
@lijli

I was only able to verify this:
Error while executing action {0}: {1}
执行动作 {0} 时出错: {1} --> {0}执行动作时出错: {1}

Screenshot is attached.

Could you please check the other message?
The steps are not specified above.
Comment 14 Lijun Li 2013-09-26 22:55:16 EDT
Verified it's fixed on is15 build: 3.3.0-0.22.master.el6ev


Strings from Zanata: ovirt->master->Documents (zh-Hans-CN):

Error while executing action {0}: {1}  执行动作 {0} 时出错: {1}

Error while executing action: {0}  执行动作时出错:{0} 


also please see the attached screenshot.
Comment 15 Lijun Li 2013-09-26 22:56:36 EDT
Created attachment 803691 [details]
Fixed_Error while executing action
Comment 16 Lijun Li 2013-09-26 23:01:21 EDT
Hi Yuko,

I found the redundant message 'Error while executing action' in Zanata,ovirt->master->Documents (zh-Hans-CN):



frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrorsSearch document in editorView in editor
	Index	Source	Target
	
1 Cannot remove Directory Group. Detach Group from  VM-Pool first. -->

Error while executing action无法删除目录组(Directory Group)。请先将组从  VM-Pool 分
^^^^^^^^^^^^^^^^^^^^^^^^^^
离。'

Should I file a bug for tracking this? Or you can ask zh_CN translator updete the string in Zanata and remove the string 'Error while executing action' from this message.
Comment 17 Yuko Katabami 2013-09-26 23:27:20 EDT
Created attachment 803699 [details]
zh-CN error message with redundant English words is now fixed.

@lijli,

This has been fixed by our zh_CN translator in Zanata.
It will be pulled together with all other changes made during the QA event to be pushed into code.
Comment 18 Itamar Heim 2014-01-21 17:11:39 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.