Bug 1001431 - RFE: feature blkmapd add help -h option, to output "usage:" info
Summary: RFE: feature blkmapd add help -h option, to output "usage:" info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
high
low
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks: 1313485 1295577
TreeView+ depends on / blocked
 
Reported: 2013-08-27 04:03 UTC by JianHong Yin
Modified: 2016-11-04 04:59 UTC (History)
5 users (show)

Fixed In Version: nfs-utils-1.3.0-0.27.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:59:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description JianHong Yin 2013-08-27 04:03:40 UTC
Description of problem:
RFE: feature blkmapd add help  -h  option,  to output "usage:" info

Version-Release number of selected component (if applicable):
[root@dhcp12-125 ~]# rpm -q nfs-utils
nfs-utils-1.2.8-2.0.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
[root@dhcp12-125 ~]# blkmapd -h
blkmapd: invalid option -- 'h'
Pid file /var/run/blkmapd.pid already existed
[root@dhcp12-125 ~]# blkmapd --help
blkmapd: invalid option -- '-'
blkmapd: invalid option -- 'h'
blkmapd: invalid option -- 'e'
blkmapd: invalid option -- 'l'
blkmapd: invalid option -- 'p'
Pid file /var/run/blkmapd.pid already existed


Expected results:
output the usage: if -h
or invalid option and then give the right usage.


Additional info:

Comment 2 RHEL Program Management 2014-03-22 06:40:46 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Steve Dickson 2016-01-20 19:58:42 UTC
commit 3a2747736666dab2c266efa07dd5a453bf9b7482
Author: Steve Dickson <steved@redhat.com>
Date:   Wed Jan 20 14:56:54 2016 -0500

    blkmapd: Added a usage routine
    
    Show the correct arguments when invalid
    arguments are used.

Comment 9 Yongcheng Yang 2016-05-23 09:26:06 UTC
[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.27.el7.x86_64
[root@ibm-x3550m4-02 ~]# blkmapd -h
Usage: blkmapd [-hdf]
[root@ibm-x3550m4-02 ~]# echo $?
0
[root@ibm-x3550m4-02 ~]# 

Move to VERIFIED and continue to run the automatic case.

Comment 11 errata-xmlrpc 2016-11-04 04:59:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.