Bug 1001443 - if no args specified, mount.nfs can not output the usage info
Summary: if no args specified, mount.nfs can not output the usage info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
medium
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
: 1001444 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-27 04:59 UTC by JianHong Yin
Modified: 2016-11-04 04:59 UTC (History)
2 users (show)

Fixed In Version: nfs-utils-1.3.0-0.29.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:59:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description JianHong Yin 2013-08-27 04:59:35 UTC
Description of problem:
if no args specified, mount.nfs  can not output the usage info

Version-Release number of selected component (if applicable):
RedHatEnterpriseWorkstation 7.0
nfs-utils-1.2.8-2.0.el7.x86_64

How reproducible:


Steps to Reproduce:
1. mount.nfs
2.
3.

Actual results:
[root@dhcp12-125 ~]# mount.nfs 
mount.nfs: no mount point provided

Expected results:
# mount.nfs 
usage: mount.nfs remotetarget dir [-rvVwfnsh] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, do not actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than fail
        -h              Print this help
        nfsoptions      Refer to mount.nfs(8) or nfs(5)

Additional info:
RHEL5 RHEL6 works fine;
From the customer's perspective, I do not think we should delete the usage info.

Comment 2 RHEL Program Management 2014-03-22 06:40:39 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Steve Dickson 2016-06-07 20:12:50 UTC
*** Bug 1001444 has been marked as a duplicate of this bug. ***

Comment 6 Steve Dickson 2016-06-07 20:16:37 UTC
This is the correct upstream commit... 

commit a528ad3147815bfc05c21a7ae69fbdbe83fddefd
Author: Steve Dickson <steved@redhat.com>
Date:   Tue Jun 7 14:32:21 2016 -0400

    mount.nfs: added usage output when no arguemnts are given
    
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 8 Yongcheng Yang 2016-06-12 02:20:52 UTC
Verified with nfs-utils-1.3.0-0.29.el7

Move to VERIFIED and continue to run the automatic case.

[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.29.el7.x86_64
[root@ibm-x3550m4-02 ~]# mount.nfs
mount.nfs: no mount point provided
usage: mount.nfs remotetarget dir [-rvVwfnsh] [-o nfsoptions]
options:
	-r		Mount file system readonly
	-v		Verbose
	-V		Print version
	-w		Mount file system read-write
	-f		Fake mount, do not actually mount
	-n		Do not update /etc/mtab
	-s		Tolerate sloppy mount options rather than fail
	-h		Print this help
	nfsoptions	Refer to mount.nfs(8) or nfs(5)

[root@ibm-x3550m4-02 ~]# umount.nfs
umount.nfs: no mount point provided
usage: umount.nfs dir [-fvnrlh]
options:
	-f	force unmount
	-v	verbose
	-n	Do not update /etc/mtab
	-r	remount
	-l	lazy unmount
	-h	print this help

[root@ibm-x3550m4-02 ~]#

Comment 10 errata-xmlrpc 2016-11-04 04:59:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.