Bug 1001468 - The bonding params need to be verified and adjusted if needed to prevent serious network degredations
The bonding params need to be verified and adjusted if needed to prevent seri...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On: 996120
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 02:24 EDT by haiyang,dong
Modified: 2015-07-13 01:19 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of: 996120
Environment:
Last Closed: 2014-01-21 14:49:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-08-27 02:24:02 EDT
+++ This bug was initially created as a clone of Bug #996120 +++

Description of problem:
"""
	It is critical that either the miimon or arp_interval and
arp_ip_target parameters be specified, otherwise serious network
degradation will occur during link failures.  Very few devices do not
support at least miimon, so there is really no reason not to use it.
"""
source: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/networking/bonding.txt#n153

To prevent this case we should check and adjust the arguments if needed during ai and the tui install.
Currently both ways to configure the device don't do any checks on the params and don't even require any params to be set.

--- Additional comment from Mike Burns on 2013-08-15 10:27:28 EDT ---

IMO (and feel free to argue):

Auto-install:  if the user specifies something for the parameters, then don't change anything.  If they don't pass any parameters, set some sane default.  We generally expect that people know what they're doing with autoinstall

TUI:  when creating a new bond, add default options, but allow the user to change/remove.  If they're editing, don't suddenly add options that weren't there before.
Comment 1 haiyang,dong 2013-08-27 02:26:34 EDT
Need to clone this bug from ovirt-node upstream into downstream to help qe track this issue in rhev-h
Comment 3 Fabian Deutsch 2013-09-17 08:41:53 EDT
The implement solution is:
Provide sane defaults (miimon=100), but let the user override them.
Comment 10 Cheryn Tan 2013-11-07 19:33:52 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 haiyang,dong 2013-12-14 00:58:40 EST
Test version:
ovirt-node-3.0.1-9.el6_5.noarch.rpm
rhevh-6.5-20131213.0.0.iso

Previously no default bond options were set, this could lead to network
connection issues. To prevent this some sane defaults are set to "mode=balance-rr miimon=100" if no other options are given at all.

so this bug has been fixed on ovirt-node-3.0.1-9.el6_5.noarch.rpm, change the status into "VERIFIED"
Comment 13 errata-xmlrpc 2014-01-21 14:49:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.