Bug 1001487 - host call trace when booting win2k8-64 guest with large memory and multiple vcpu
host call trace when booting win2k8-64 guest with large memory and multiple vcpu
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 03:13 EDT by Xu Han
Modified: 2013-09-09 21:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 21:34:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host dmesg log (70.28 KB, text/plain)
2013-08-27 03:24 EDT, Xu Han
no flags Details

  None (edit)
Description Xu Han 2013-08-27 03:13:46 EDT
Description of problem:
host call trace when booting win2k8-64 guest with large memory and multiple vcpu and guest boot take more than 10min.
win2k8r2-64 hit this issue, but win2k3-32/64, win8-32/64, win2012-64 won't

I added dmesg log to attachment.

Version-Release number of selected component (if applicable):
kernel:3.10.0-11.el7.x86_64
qemu:qemu-kvm-1.5.2-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.verify mem and cpu in host
#free -g
             total       used       free     shared    buffers     cached
Mem:           503         67        435          0          0         62
-/+ buffers/cache:          5        498
Swap:            3          0          3

#cat /proc/cpuinfo(total 48 cores) 

....
processor       : 47
vendor_id       : AuthenticAMD
cpu family      : 16
model           : 9
model name      : AMD Opteron(tm) Processor 6172


2.clear dmesg
#dmesg -c

3.boot guest(not overcommit)
#/usr/libexec/qemu-kvm -name vm1 -nodefaults \
-m 420G \
-smp 32,cores=8,threads=1,sockets=4 \
-M pc-i440fx-rhel7.0.0 -cpu Opteron_G3 -rtc base=utc,clock=host,driftfix=slew -k en-us -boot menu=on -monitor stdio -vnc :2 -spice disable-ticketing,port=5932 -vga qxl -qmp tcp:0:5556,server,nowait -drive file=/home/win2008-x64.qcow2,if=none,id=disk,format=qcow2,cache=none,werror=stop,rerror=stop -device ide-hd,drive=disk,bus=ide.1,unit=0,id=disk0,bootindex=1 -balloon virtio

Actual results:
guest boot take more than 10min and host call trace

Expected results:
guest can boot with no errors

Additional info:
I will update test result in Intel host later
Comment 1 Xu Han 2013-08-27 03:24:03 EDT
Created attachment 790810 [details]
host dmesg log
Comment 3 Luiz Capitulino 2013-09-05 09:53:27 EDT
The host kernel seems to be spinning on a spinlock for 22s!

Is that machine on virtlab? I don't have any machine that big around, so I'll have to look for one to try to reproduce the issue.

Something you could do, is to get a kernel dump, store in it in the machine itself and let me log in.
Comment 4 juzhang 2013-09-05 21:31:10 EDT
(In reply to Luiz Capitulino from comment #3)
> The host kernel seems to be spinning on a spinlock for 22s!
> 
> Is that machine on virtlab? I don't have any machine that big around, so
> I'll have to look for one to try to reproduce the issue.
> 
> Something you could do, is to get a kernel dump, store in it in the machine
> itself and let me log in.

Hi Hanxu,

Can you reply this info?
Comment 7 Luiz Capitulino 2013-09-09 10:16:47 EDT
There's a number of fixes between kernels 3.10.0-11.el7 and 3.10.0-15.el7. If you really can't get the issue anymore with latest kernel, then I think you should close this bz as WORKSFORME.
Comment 8 Xu Han 2013-09-09 21:34:50 EDT
According to comment 6 and comment 7, set this bug as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.