Bug 1001494 - RFE: feature, add "[Uu]sage:" string in the nfsdcltrack -h output info ;
RFE: feature, add "[Uu]sage:" string in the nfsdcltrack -h output info ;
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.0
All Linux
low Severity low
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
Milan Navratil
: EasyFix, FutureFeature, Patch
Depends On:
Blocks: 1385242
  Show dependency treegraph
 
Reported: 2013-08-27 03:27 EDT by Yin.JianHong
Modified: 2017-08-01 15:48 EDT (History)
6 users (show)

See Also:
Fixed In Version: nfs-utils-1.3.0-0.34.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 15:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-08-27 03:27:45 EDT
Description of problem:
RFE: feature, add "[Uu]sage:" string in the nfsdcltrack -h output info;

in other nfs-utils commands, the usage info begin with string "usage:" or "Usage:"
I think that's better to add "usage:" in the begin of nfsdcltrack's output info.

Version-Release number of selected component (if applicable):
RedHatEnterpriseWorkstation 7.0
nfs-utils-1.2.8-2.0.el7.x86_64


How reproducible:


Steps to Reproduce:
1. nfsdcltrack -h 
2.
3.

Actual results:
# nfsdcltrack -h
nfsdcltrack [ -hfd ] [ -s dir ] < cmd > < arg >
Where < cmd > is one of the following and takes the following < arg >:
    init
    create <nfs_client_id4>
    remove <nfs_client_id4>
    check  <nfs_client_id4>
    gracedone <epoch time>


Expected results:
# nfsdcltrack -h
usage: nfsdcltrack [ -hfd ] [ -s dir ] < cmd > < arg >
Where < cmd > is one of the following and takes the following < arg >:
    init
    create <nfs_client_id4>
    remove <nfs_client_id4>
    check  <nfs_client_id4>
    gracedone <epoch time>


Additional info:
other commands output:
[root@dhcp12-125 ~]# rpc.mountd -h
Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
        [-o num|--descriptors num] [-f exports-file|--exports-file=file]
        [-p|--port port] [-V version|--nfs-version version]
        [-N version|--no-nfs-version version] [-n|--no-tcp]
        [-H ha-callout-prog] [-s|--state-directory-path path]
        [-g|--manage-gids] [-t num|--num-threads=num]
[root@dhcp12-125 ~]# rpc.nfsd -h
Usage:
rpc.nfsd [-d|--debug] [-H hostname] [-p|-P|--port port] [-N|--no-nfs-version version] [-V|--nfs-version version] [-s|--syslog] [-T|--no-tcp] [-U|--no-udp] nrservs

# mount.nfs -h
usage: mount.nfs remotetarget dir [-rvVwfnsh] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, do not actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than fail
        -h              Print this help
        nfsoptions      Refer to mount.nfs(8) or nfs(5)
Comment 2 RHEL Product and Program Management 2014-03-22 02:40:31 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Mark Thacker 2016-11-23 12:29:08 EST
Added pm_ack and placed this into the RHEL 7.4 Filesystems and Storage RPL
Comment 7 Yin.JianHong 2017-05-30 23:55:11 EDT
[root@bkr-hv01-guest07 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.43.el7.x86_64
[root@bkr-hv01-guest07 ~]# nfsdcltrack -h
Usage: nfsdcltrack [ -hfd ] [ -s dir ] < cmd > < arg >
Where < cmd > is one of the following and takes the following < arg >:
    init
    create <nfs_client_id4>
    remove <nfs_client_id4>
    check  <nfs_client_id4>
    gracedone <epoch time>
[root@bkr-hv01-guest07 ~]#
Comment 10 errata-xmlrpc 2017-08-01 15:48:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2233

Note You need to log in before you can comment on or make changes to this bug.