Bug 1001497 - Validation of guided rules fails if the project contains Globals definition
Validation of guided rules fails if the project contains Globals definition
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER3
: 6.0.0
Assigned To: manstis
Jiri Locker
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 03:31 EDT by Jiri Locker
Modified: 2014-08-06 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2013-08-27 03:31:03 EDT
Description of problem:
After clicking Validate button on any type of Guided Rule (including GDT) error message pops up with message:

* [ERR 107] Line 1:0 mismatched input '<' expecting one of the following tokens: '[package, import, global, declare, function, rule, query]'.
	
* Parser returned a null Package

It is quite confusing because there is no '<' character in the first line of the rule source. Moreover there is nothing wrong with the rule being validated -- the error occurs only if the project contains a Globals definition file, even an empty one.

Version-Release number of selected component (if applicable):
ER1

How reproducible:
-

Steps to Reproduce:
1. navigate to mortgages project
2. create new Globals Definition (New Item > Global Variable(s)) and save it
3. open any guided rule, e.g. CreditApproval and click Validation

Actual results:
Validation error.

Expected results:
No validation error.

Additional info:
Comment 2 manstis 2013-08-29 09:01:27 EDT
The same problem would occur if the project contained a DSL.
Comment 3 Jiri Locker 2013-09-30 04:49:56 EDT
Fixed in ER3.

Note You need to log in before you can comment on or make changes to this bug.