Bug 1001527 - FindProcessInstanceCommand cannot be marshalled
FindProcessInstanceCommand cannot be marshalled
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Marco Rietveld
Ivo Bek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 04:43 EDT by Ivo Bek
Modified: 2016-09-20 01:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
response and stacktrace (6.10 KB, text/plain)
2013-09-19 10:11 EDT, Ivo Bek
no flags Details

  None (edit)
Description Ivo Bek 2013-08-27 04:43:20 EDT
Description of problem:

The FindProcessInstanceCommand and FindProcessInstancesCommand don't contain any anotations to be marshalled. I mean the XML bind annotations. These commands are important to get logs about process instances via JMS API, there is no other option because GetProcessInstanceCommand returns just details about the running process instances.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Marco Rietveld 2013-08-29 03:50:21 EDT
Fixed with this commit: 

https://github.com/droolsjbpm/jbpm/commit/664970cff10f40c7fd8e96555715effb441bd251

Please set the milestone and set the BZ to modified.
Comment 2 Ivo Bek 2013-09-19 10:11:13 EDT
Still, it's not possible to marshall FindProcessInstanceCommand. I use following class and method to marshall it:

String xmlStr = JaxbSerializationProvider.convertJaxbObjectToString(req);

Seems, the Jaxb context doesn't know about the class or its super class. I will attach response and stacktrace with the exception.
Comment 3 Ivo Bek 2013-09-19 10:11:48 EDT
Created attachment 799973 [details]
response and stacktrace
Comment 9 Ivo Bek 2013-12-04 03:33:09 EST
Verified in BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.