Bug 1001546 - [de_DE, es_ES][RHEVM3.3][Admin Portal] - Indentation error found on New Network QoS page under Data Center Tab
[de_DE, es_ES][RHEVM3.3][Admin Portal] - Indentation error found on New Netwo...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
All Linux
high Severity medium
: ---
: 3.3.0
Assigned To: Gilad Chaplik
Yuko Katabami
i18n
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 05:13 EDT by Satyabrata Maitra
Modified: 2016-02-10 14:00 EST (History)
13 users (show)

See Also:
Fixed In Version: is17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: i18n
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot: NewNetworkQoS - Locales Comparison (40.98 KB, image/png)
2013-09-06 12:52 EDT, Einav Cohen
no flags Details
NewNetworkQoS - Improvement Suggestion (42.29 KB, image/png)
2013-09-06 12:53 EDT, Einav Cohen
no flags Details
NewNetworkQoS - Improvement Suggestion 2 (23.25 KB, image/png)
2013-09-06 12:54 EDT, Einav Cohen
no flags Details
Fixed New Network QoS (23.11 KB, image/png)
2013-10-11 04:25 EDT, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19356 None None None Never
oVirt gerrit 19642 None None None Never

  None (edit)
Description Satyabrata Maitra 2013-08-27 05:13:54 EDT
Description of problem:
There are some indentation error found in Admin Portal --> Data Center --> Network QoS --> New.
It generally happens due to long translation strings and fixed size of the levels, buttons properties. For the first case, its a translation error, otherwise, its an i18n error and needs to be fixed in the design level by devel.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualisationsmanager Version: 3.3.0-0.16.master.el6ev

How reproducible:
Always

Steps to Reproduce:
1. Login with correct login credentials in RHEVM Admin Portal with de_DE locale
2. Go to Data Center --> Network QoS tab
3. Click on New
4. Observe the Indentation of Inbound and Outbound heads and its values.

Actual results:
Indentation error happening due to translation or design error

Expected results:
There should be no indentation problem.

Additional info:
Screen shot attached with red arrow marks towards the errors.
Comment 1 Doron Fediuck 2013-08-28 10:24:24 EDT
(In reply to Satyabrata Maitra from comment #0)
> 
> Additional info:
> Screen shot attached with red arrow marks towards the errors.

Attachment is missing. Can you please provide it?
Comment 2 Satyabrata Maitra 2013-08-29 23:43:16 EDT
Created attachment 791994 [details]
de_DE error in new network QoS page Admin portal

Same happening for es_ES as well.
Comment 3 Einav Cohen 2013-09-06 12:52:42 EDT
Created attachment 794888 [details]
screen-shot: NewNetworkQoS - Locales Comparison
Comment 4 Einav Cohen 2013-09-06 12:53:47 EDT
Created attachment 794889 [details]
NewNetworkQoS - Improvement Suggestion
Comment 5 Einav Cohen 2013-09-06 12:54:15 EDT
Created attachment 794890 [details]
NewNetworkQoS - Improvement Suggestion 2
Comment 6 Einav Cohen 2013-09-06 13:06:34 EDT
see attachment 794888 [details] - it seems that the indentation behavior is pretty-much consistent across all locales, including English. 

the only problem that I see in the non-English locales is an horizontal scroll-bar that appears at the bottom of the dialog.

I suggest to do one of the following:

(a) extend the dialog width to accommodate longer strings without having a horizontal scroll-bar.

(b) change the layout of the dialog according to one of the attached suggestions:

  (1) attachment 794889 [details] (a better alignment of the visual components will reduce the horizontal real-estate that the current content is occupying).

  (2) attachment 794890 [details] (more of a "classic" components arrangement, which might take a little more vertical real-estate, but will eliminate / reduce layout problems such as the current one to minimum).
Comment 7 Eldan Hildesheim 2013-09-17 10:30:49 EDT
Option 1 is better to serve as a widget.
It's compact and can be implemented graphically in a nice way.
There could be a small problem of language translation (width of the words: average, peak burst) but it won't be terrible.

Option 2 layout is better in point of view of translation (long words)
But it will be worst to serve as a widget in another dialogue cause it's too long.

My opinion: option 1
Comment 8 Lijun Li 2013-10-11 04:22:42 EDT
Verified it's fixed on is18 build: rhevm-3.3.0-0.25.beta1.el6ev.noarch.rpm

Please see the attached screenshot.
Comment 9 Lijun Li 2013-10-11 04:25:01 EDT
Created attachment 810913 [details]
Fixed New Network QoS
Comment 10 Itamar Heim 2014-01-21 17:29:43 EST
Closing - RHEV 3.3 Released
Comment 11 Itamar Heim 2014-01-21 17:29:43 EST
Closing - RHEV 3.3 Released
Comment 12 Itamar Heim 2014-01-21 17:32:43 EST
Closing - RHEV 3.3 Released
Comment 13 Dave Wysochanski 2015-02-11 17:23:02 EST
Created attachment 990670 [details]
Simple test case for this bug
Comment 14 Dave Wysochanski 2015-02-11 17:24:41 EST
Created attachment 990671 [details]
test rpm with patch V3 patch from Ben in https://bugzilla.redhat.com/attachment.cgi?id=981565

Note You need to log in before you can comment on or make changes to this bug.