Bug 1001633 - [as7] system property created at the time of server group creation will not persist
[as7] system property created at the time of server group creation will not p...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified Unspecified
unspecified Severity high
: DR01
: JON 3.2.1
Assigned To: Libor Zoubek
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 08:34 EDT by Dasharath Masirkar
Modified: 2015-11-01 19:43 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 13:44:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 465713 None None None Never

  None (edit)
Description Dasharath Masirkar 2013-08-27 08:34:00 EDT
Description of problem:
The system property created at the time of server group creation will not exist once the server group created successfully. It require additional effort to recreate it again on newly created server group.
 

Version-Release number of selected component (if applicable):
3.1.2

How reproducible:
Always

Steps to Reproduce:
1. Import domain EAP 6 server into JON inventory
2. in JON, go to the Domain controller, right click and select 'create child - servergroup'
3. enter name, click 'next'
4. choose profile and socket bindings
5. Add a system property (for example 'UseJK', with value 'true'), set 'boot time to true', click 'OK'
6. Observe that the property is in the list, but yet 'boot time' is not marked
7. click 'finish'
8. Observe in JON that the new server group exists, but without the property, this can also be verified with the EAP management console.

Actual results:
System property created at the time of server group creation will not persist into server group configuration.

Expected results:
System property created at the time of server group creation must be persist into server group configuration.

Additional info:
Comment 2 Libor Zoubek 2014-02-07 09:21:15 EST
in master

commit 07ceb9373badce39b10151ddef36ce8183fb19d2
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Fri Feb 7 15:06:15 2014 +0100
Comment 3 Thomas Segismont 2014-02-07 17:05:02 EST
Tested and cherry-picked over to release/jon3.2.x

commit d06aa46c093520cf19186205aae0bb7a0b880271
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Fri Feb 7 15:06:15 2014 +0100

(cherry picked from commit 07ceb9373badce39b10151ddef36ce8183fb19d2)
Signed-off-by: Thomas Segismont <tsegismo@redhat.com>
Comment 4 Simeon Pinder 2014-02-18 10:08:37 EST
Moving to ON_QA as available for testing in the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=336752

Note: the installed version is still JON 3.2.0.GA by design and this represents part of the payload for JON 3.2.1 also known as cumulative patch 1 for 3.2.0.GA.  How this will be delivered to customers is still being discussed.
Comment 5 Sunil Kondkar 2014-02-21 03:02:24 EST
Verified on JON 3.2.1 DR01 build (Build Number :c758688:4c03150)

Followed the steps and verified that system property created at the time of server group creation exists in server group configuration.
Comment 6 Mike Foley 2014-05-08 13:44:13 EDT
JON 3.2.1 released week of 5/5/2014

Note You need to log in before you can comment on or make changes to this bug.