Bug 1001645 - harfbuzz: misuse of snprintf return value
harfbuzz: misuse of snprintf return value
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: harfbuzz (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Parag Nemade
QE Internationalization Bugs
: i18n
Depends On:
Blocks: 1001533
  Show dependency treegraph
 
Reported: 2013-08-27 08:59 EDT by Florian Weimer
Modified: 2014-06-18 04:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: harfbuzz-0.9.20-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:02:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-08-27 08:59:12 EDT
src/hb-buffer-serializer.cc:_hb_buffer_serialize_glyphs_json() misuses return value from snprintf().  Same for _hb_buffer_serialize_glyphs_text() and hbsrc/hb-shape.cc:_feature_to_string().  These cases are likely harmless because they do not happen inside a loop which could actually overflow the buffer.
Comment 2 Behdad Esfahbod 2013-08-27 10:50:09 EDT
In all three cases it's guaranteed that they don't overflow the buffer.  I'm still not sure how this is "misuse".  As such, I'm not sure what there is to fix.
Comment 3 Behdad Esfahbod 2013-08-27 10:51:02 EDT
Ok, I now understand what you mean by misuse.  But I think the code is fine the way it is.
Comment 4 Florian Weimer 2013-08-27 11:05:45 EDT
What I meant: snprintf can return -1 on error (glibc calls malloc in some cases which could fail; the Harfbuzz code doesn't deal with that), and if the buffer is too small, it returns the non-truncated number of characters, not the length of the truncated string.
Comment 5 Behdad Esfahbod 2013-08-27 11:47:08 EDT
Pushed out a fix for the negative return.  Thanks.
Comment 6 Parag Nemade 2013-08-30 03:55:38 EDT
Thanks behdad for quick fix. I have built harfbuzz-0.9.20-1.el7 now.
Comment 9 Parag Nemade 2014-01-14 06:22:27 EST
I am going to file errata as errata is needed for each package against whom bug is available and fixed.

Florian,
   I suppose when Akira gave devel-ack+, bugbot should have changed bug status from ON_QA to MODIFIED.
Comment 13 Ludek Smid 2014-06-13 06:02:09 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.