Bug 1001657 - SELinux is preventing /usr/bin/nautilus from 'write' accesses on the directory net.
SELinux is preventing /usr/bin/nautilus from 'write' accesses on the director...
Status: CLOSED DUPLICATE of bug 1001650
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e752dce3f36b68686fde26a1a63...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 09:18 EDT by José Antonio
Modified: 2013-08-27 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 10:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description José Antonio 2013-08-27 09:18:38 EDT
Description of problem:
SELinux is preventing /usr/bin/nautilus from 'write' accesses on the directory net.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that nautilus should be allowed write access on the net directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep pool /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                system_u:system_r:init_t:s0
Target Objects                net [ dir ]
Source                        pool
Source Path                   /usr/bin/nautilus
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nautilus-3.8.2-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.9-200.fc19.x86_64 #1 SMP Wed
                              Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-27 14:10:57 WEST
Last Seen                     2013-08-27 14:10:57 WEST
Local ID                      64de797e-2e7d-4966-b38a-27a0e32d3b5f

Raw Audit Messages
type=AVC msg=audit(1377609057.165:557): avc:  denied  { write } for  pid=4070 comm="pool" name="net" dev="proc" ino=2023 scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=dir


type=SYSCALL msg=audit(1377609057.165:557): arch=x86_64 syscall=access success=yes exit=0 a0=7f595c00f420 a1=2 a2=7f595c00f008 a3=fff00000 items=0 ppid=4023 pid=4070 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=1 tty=pts3 comm=pool exe=/usr/bin/nautilus subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: pool,unconfined_t,init_t,dir,write

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.9-200.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-27 10:56:04 EDT

*** This bug has been marked as a duplicate of bug 1001650 ***

Note You need to log in before you can comment on or make changes to this bug.