Bug 1001669 - openstack-cinder: No error massage in the log when system fail to create a volume
openstack-cinder: No error massage in the log when system fail to create a vo...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
3.0
x86_64 Linux
unspecified Severity medium
: ---
: 4.0
Assigned To: Eric Harney
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 09:41 EDT by Yogev Rabl
Modified: 2016-04-26 10:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 07:46:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cinder log files from /var/log/cinder (359.29 KB, application/x-gzip)
2013-08-27 09:41 EDT, Yogev Rabl
no flags Details
the rhos3 manual (1.66 MB, application/pdf)
2013-08-27 09:43 EDT, Yogev Rabl
no flags Details

  None (edit)
Description Yogev Rabl 2013-08-27 09:41:34 EDT
Created attachment 790976 [details]
Cinder log files from /var/log/cinder

Description of problem:
The OpenStack-Cinder is has a gluster storage with two nodes, the XFS file system can't create more the 50GB sized volume. 
Though the Cinder failed to create the volume, there were no error/warning massages in any of the logs. After the creation attempt the status of the volume was 'Error'. 

Version-Release number of selected component (if applicable):
openstack-cinder-2013.1.3-2.el6ost

How reproducible:
Configure the OpenStack-cinder to work with gluster with two node according to the manual attached (see appendix B). 
 

Steps to Reproduce:
1. Create a volume, 100 GB in size with nova volume-create command.
2. Create a volume, 100 GB in size in the webUI. 
3. Create a volume, 10 GB in size with the nova-cli & weUI. 
4. Check the cinder logs for errors with regarding the 100GB volumes.  

Actual results:
There are no errors nor any indication in the logs that the volume creation failed.

Expected results:
The logs should show errors about the failure of the volume creation. 

Additional info:
1.The Cinder logs are attached.
2. The manaul explainig how to configure the cinder with gluster - see appendix B.
Comment 1 Yogev Rabl 2013-08-27 09:43:02 EDT
Created attachment 790979 [details]
the rhos3 manual
Comment 3 Eric Harney 2013-08-27 10:26:24 EDT
The error for this condition appears in the cinder-scheduler log as:

2013-08-27 15:29:58  WARNING [cinder.scheduler.filters.capacity_filter] Insufficient free space for volume creation (requested / avail): 100/49.0
2013-08-27 15:29:58    ERROR [cinder.scheduler.manager] Failed to schedule_create_volume: No valid host was found. 


This indicates that the scheduler received a request for a 100GB volume allocation but only saw 49GB free, so it filtered that host, and no host was found that satisfied the request.  The cinder-volume log will not show an error in this scenario because the request is never sent to that service.


Another 50GB attempt:
2013-08-27 16:09:45  WARNING [cinder.scheduler.filters.capacity_filter] Insufficient free space for volume creation (requested / avail): 50/49.0
2013-08-27 16:09:45    ERROR [cinder.scheduler.manager] Failed to schedule_create_volume: No valid host was found.

Note You need to log in before you can comment on or make changes to this bug.