Bug 1001674 - Automatic provides in scl-based packages
Automatic provides in scl-based packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: doc-Software_Collections_Guide (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.4
Assigned To: Petr Kovar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 09:46 EDT by Jan Zeleny
Modified: 2014-06-04 10:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 10:27:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Zeleny 2013-08-27 09:46:57 EDT
I have been investigating some problems with automatically generated provides in scl-based packages [1].

The use case is:
- I have a scl-based package that contains some libraries
- these libraries are automatically included in package's Provides
- the problem is that some system packages might provide the same library and there might be an application that requires the library
- in such case yum can select for installation either package that provides the library
- in case it selects the scl-based package, the application will very likely misbehave, as it will most likely not link with the scl-based library due to non-standard paths

Now with this use case in mind, we have tried to come up with a solution how to prefix the library symbol in package's Provides. On RHEL7 this is doable by utilizing %__provides_exclude_from macro. However rpm on RHEL6 doesn't support the macro and it is therefore impossible to prefix the library symbol.

We would like to document the situation and how to do the prefix (see [1] and a spec file in [2] for details). Also please document that this doesn't work for RHEL < 7.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=953499
[2] http://koji.katello.org/koji/buildinfo?buildID=4101

Note You need to log in before you can comment on or make changes to this bug.