Bug 1001705 - Failure when adding new record: "Error while adding record: no available memory"
Failure when adding new record: "Error while adding record: no available memory"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.5
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Chris Leech
Bruno Goncalves
: Regression, TestBlocker
Depends On:
Blocks: 1049922 1066116
  Show dependency treegraph
 
Reported: 2013-08-27 10:40 EDT by Gadi Ickowicz
Modified: 2014-08-21 21:41 EDT (History)
9 users (show)

See Also:
Fixed In Version: iscsi-initiator-utils-6.2.0.873-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1049922 1066116 (view as bug list)
Environment:
Last Closed: 2013-11-21 18:10:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar file of /var/lib/iscsi (30.00 KB, application/x-tar)
2013-08-27 10:40 EDT, Gadi Ickowicz
no flags Details
vdsm logs (1.23 MB, application/x-gzip)
2013-08-27 10:44 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2013-08-27 10:40:44 EDT
Created attachment 791017 [details]
tar file of /var/lib/iscsi

Description of problem:
when vdsm attempts to add a new record to the iscsi database it fails with the following error, and rc = 3:
iscsiadm: Error while adding record: no available memory.

The commands that were run:
/usr/bin/sudo -n /sbin/iscsiadm -m discoverydb -t sendtargets -I default -p <server> --discover (succeeds)

/usr/bin/sudo -n /sbin/iscsiadm -m node -T <target> -I default -p <server> --op=new (fails)

Version-Release number of selected component (if applicable):
vdsm-4.12.0-72.git287bb7e.el6ev.x86_64
iscsi-initiator-utils-6.2.0.873-5.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Add second host to existing iscsi datacenter on rhevm 

Actual results:
Host becomes non-operational due to error when connecting to storage

Additional info:
tar file of /var/lib/iscsi attached
Comment 1 Gadi Ickowicz 2013-08-27 10:44:25 EDT
Created attachment 791018 [details]
vdsm logs
Comment 5 Chris Leech 2013-08-27 17:01:05 EDT
This looks like a regression caused by a problem in the fix for #884427.

The GLOB_NOMATCH return code is being passed along in idmb_rec_write_old, and later taken to be ISCSI_ERR_NOMEM as they are the same value.  A no-match in glob here is not an error, and the return code needs to be reset to 0.
Comment 12 Bruno Goncalves 2013-09-12 09:59:46 EDT
Reproduced the same issue on iscsi-initiator-utils-6.2.0.873-6

iscsiadm -m discoverydb -t sendtargets -I default -p <server> --discover
[  OK  ] iscsid: [  OK  ]

[root@storageqe-17 ~]# iscsiadm -m node -T <target> -I default -p <server> --op new
iscsiadm: Error while adding record: no available memory


----

Fixed on iscsi-initiator-utils-6.2.0.873-8.el6

iscsiadm -m discoverydb -t sendtargets -I default -p <server> --discover
[  OK  ] iscsid: [  OK  ]

[root@storageqe-17 ~]# iscsiadm -m node -T <target> -I default -p <server> --op new
New iSCSI node [tcp:[hw=,ip=,net_if=,iscsi_if=default] <server>,3260,-1 <target>] added
Comment 13 errata-xmlrpc 2013-11-21 18:10:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1700.html

Note You need to log in before you can comment on or make changes to this bug.