Bug 1001709 - RAM Snapshot restore fails when guest usb is set to disabled or legacy
RAM Snapshot restore fails when guest usb is set to disabled or legacy
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.3
Assigned To: Arik
Haim
virt
:
Depends On: 1008340 1011520
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 10:49 EDT by Jason Brooks
Modified: 2013-09-30 10:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 10:11:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Brooks 2013-08-27 10:49:25 EDT
Description of problem:

Restoring a snapshot with RAM fails if the guest instance configured with usb disabled (the default) or usb legacy.

Version-Release number of selected component (if applicable):

Tested with F19 AIO install w/ oVirt 3.3RC, with guests running F19 and CentOS 6.4.

How reproducible:


Steps to Reproduce:
1. Create a VM in oVirt (usb will be set to disabled by default)
2. Start VM and take live snapshot, with "Save Memory" checked
3. Turn off VM, preview snapshot, start VM

Actual results:

VM won't start.

Expected results:

VM starts, restores state from snapshot.

Additional info:

I can run those steps 1-3 above, after switching to "native" usb, and it works as expected. "legacy" usb gives same results as disabled usb.

This appears to be the relevant log chunk from vdsm.log:

Thread-101353::ERROR::2013-08-26 15:28:58,806::vm::2062::vm.Vm::(_startUnderlyingVm) vmId=`da8cfa29-f8b8-4876-a1ae-13db996635b2`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 2022, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/vm.py", line 2890, in _run
    self._connection.restoreFlags(fname, srcDomXML, 0)
  File "/usr/lib64/python2.7/site-packages/vdsm/libvirtconnection.py", line 76, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3346, in restoreFlags
    if ret == -1: raise libvirtError ('virDomainRestoreFlags() failed', conn=self)
libvirtError: unsupported configuration: Target controller type ide does not match source usb
Thread-101353::DEBUG::2013-08-26 15:28:58,812::vm::2448::vm.Vm::(setDownStatus) vmId=`da8cfa29-f8b8-4876-a1ae-13db996635b2`::Changed state to Down: unsupported configuration: Target controller type ide does not match source usb
Comment 1 Arik 2013-09-12 07:56:29 EDT
I couldn't reproduce it on rhel, and it takes me some time to be able to check it on fedora.
In the meantime, can you please check on that specific environment where the bug is reproduced, whether the suspend & restore from suspension operations work for those VMs that could not restore snapshot with memory (with disabled/legacy usb support) ?
Comment 2 Arik 2013-09-30 10:11:02 EDT
fixed by the solution for bz 1008340
verified with libvirt-1.0.5.6-2.fc19

Note You need to log in before you can comment on or make changes to this bug.