Bug 1001737 - subscription-manager --autosubscribe does not subscribe the RHEL 6.1 and RHEL 6.2 boxes
subscription-manager --autosubscribe does not subscribe the RHEL 6.1 and RHEL...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Carter Kozak
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-27 11:42 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:22:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-08-27 11:42:31 EDT
Description of problem:
subscription-manager --autosubscribe does not subscribe the RHEL 6.1 and RHEL 6.2 boxes

Version-Release number of selected component (if applicable):
* candlepin-0.8.21-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.21-1.el6sam.noarch
* candlepin-tomcat6-0.8.21-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-8.el6sat.noarch
* katello-cli-common-1.4.3-8.el6sat.noarch
* katello-common-1.4.3-9.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
* katello-headpin-1.4.3-9.el6sam_splice.noarch
* katello-headpin-all-1.4.3-9.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarc

How reproducible:
Always


Steps to Reproduce:
1. Install RHEL 6.1 or RHEL 6.2 from beaker
2. autosubscribe to a qe account to portal live
#rpm -qa | grep subscription-manager
subscription-manager-0.95.11-1.el6.x86_64

# subscription-manager register --username=$liveportalaccount --password=$password --autosubscribe
The system with UUID 548a5ec9-08e8-43d8-b04d-849d1098e0ac has been unregistered
The system has been registered with id: 593ee00a-72ac-4e2f-bd88-cffd7ef3318
Installed Product Current Status:
ProductName:                 Red Hat Enterprise Linux Server
Status:                       Not Subscribed  

# yum repolist
(no repos listed)

3. Then removed --autosubscribed
# subscription-manager register --username=$liveportalaccount --password=$password

4. Manually subscribed to a pool - then it subscribed
subscription-manager subscribe --pool $pool_id

5. Try listing repos
# yum repolist
(listed all right repos)

Actual results:
The system did not autosubscribe

Expected results:
The system should have been autosubscribed

Additional info:
Since the error is happening on the portal side, I do not have access to any logs.
Comment 1 Carter Kozak 2013-08-27 16:49:14 EDT
I don't think this is a candlepin bug.  I can create a subscription for the installed product on my local candlepin, and it auto-subscribes just fine.  I think there's a problem with the data.
Comment 2 Carter Kozak 2013-09-03 09:53:13 EDT
This was a bug with a hotfixed version of candlepin in production.  There is a patched version live now which has fixed the problem.
Comment 3 sthirugn@redhat.com 2013-09-06 01:47:40 EDT
VERIFIED.

* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-12.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-12.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-12.el6sam_splice.noarch
* katello-headpin-1.4.3-12.el6sam_splice.noarch
* katello-headpin-all-1.4.3-12.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 5 errata-xmlrpc 2013-10-01 07:22:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.