Bug 1001739 - Support CRL propagation to Capsules
Support CRL propagation to Capsules
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
: 1145708 (view as bug list)
Depends On: 1145708
Blocks: sat6-pulp-future
  Show dependency treegraph
 
Reported: 2013-08-27 11:47 EDT by Justin Sherrill
Modified: 2017-07-26 15:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1145708 (view as bug list)
Environment:
Last Closed: 2015-03-20 13:33:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 253 Normal CLOSED - WONTFIX Support CRL propagation to Capsules Never

  None (edit)
Description Justin Sherrill 2013-08-27 11:47:21 EDT
Description of problem:

Currently the CRL from the pulp server is not propagated to the nodes.  Katello needs this so that systems who have had their certificates revoked on the server will also have them revoked on the nodes
Comment 1 Jeff Ortel 2014-05-07 11:45:43 EDT
The interval in which CRLs expire and need to be updated seems different than the interval for syncing nodes.  I don't think we want users doing a node sync just to keep their CRLs updated.  IMHO, that should be a different mechanism.  This bug should not be worked until this is resolved.
Comment 2 Brian Bouterse 2014-08-25 14:59:21 EDT
With 2.4.0, Pulp implements CRL revocation using the webserver's CRL support which typically is Apache. Users who want to apply CRLs to Pulp servers or Nodes will need to distribute the CRLs outside of Pulp.
Comment 5 Michael Hrivnak 2015-03-03 14:27:08 EST
CRLs are currently enforced by apache directly, without involvement from pulp. Pulp does not propagate apache configs to nodes, so this would be likely be in the domain of config management.

Put another way, sat6 should have apache configured to use CRLs from *somewhere*, but I don't know what that source is. Whatever the source is, making it available on capsules is outside of pulp's scope.
Comment 7 Brian Bouterse 2015-03-05 16:46:02 EST
*** Bug 1145708 has been marked as a duplicate of this bug. ***
Comment 8 Brian Bouterse 2015-03-20 13:00:39 EDT
The Pulp upstream bug status is at CLOSED - WONTFIX. Updating the external tracker on this bug.
Comment 9 Brian Bouterse 2015-03-20 13:00:40 EDT
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.
Comment 10 Mike McCune 2015-03-20 13:33:53 EDT
This isn't going to be implemented in any time in the near future. The current situation is an acceptable tradeoff.

Clients will continue to get content until their subscriptions are refreshed.

Note You need to log in before you can comment on or make changes to this bug.