Bug 1001745 - 'debug' on the kernel command line causes boot failure
'debug' on the kernel command line causes boot failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: systemd-maint
Jan Ščotka
:
: 1001075 (view as bug list)
Depends On: 1001744
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 12:05 EDT by Eric Paris
Modified: 2014-06-13 05:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: systemd-206-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1001744
Environment:
Last Closed: 2014-06-13 05:20:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2013-08-27 12:05:34 EDT
+++ This bug was initially created as a clone of Bug #1001744 +++

Remove 'rhgb quiet' from the kernel command line in the grub config and add 'debug'.  The system will mostly hang right after it says 'Welcome to $DISTRO'.

It isn't completely dead, as I still get one log line every minute or so.  But 10 minutes the system is clearly not booted and has made no visible progress.  I wonder if there is a sleep 60 type line in the debug code path somewhere?
Comment 2 Lukáš Nykrýn 2013-09-11 07:23:22 EDT
*** Bug 1001075 has been marked as a duplicate of this bug. ***
Comment 7 Ludek Smid 2014-06-13 05:20:39 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.