Bug 1001757 - regression: Xorg -configure stopped working
regression: Xorg -configure stopped working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Regression
Depends On: 921909
Blocks: 1016854
  Show dependency treegraph
 
Reported: 2013-08-27 12:42 EDT by Alon Levy
Modified: 2014-10-14 00:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 921909
: 1016854 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:52:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Søren Sandmann Pedersen 2013-09-09 17:51:05 EDT
I get the error message:

      Number of created screens does not match number of detected
      devices.  Configuration failed.

and then no file is created. However, I get that with a physical Intel chip as well, and it appears to be a general RHEL 6.4 bug.

Gerd, can you be more specific about what happens when you run X -configure?
Comment 4 Gerd Hoffmann 2013-09-10 02:29:04 EDT
Pheww, it's been a while.  Now I see exactly the same behavior you are seeing.

IIRC it was a different failure mode a few months back, with the versions
in the initial report:  "X -configure" successfully created a config file,
but "X -config $newfile" failed to start with it.
Comment 5 Søren Sandmann Pedersen 2014-06-10 12:05:23 EDT
Looking at this again, there are at least two problems.

The first problem is that the modesetting driver is chosen in preference to the qxl driver during "-configure" processing. That is wrong since modesetting is a fallback driver that shouldn't be chosen ahead of a hardware specific driver. The fix for this is available upstream:

    http://cgit.freedesktop.org/xorg/xserver/commit/?id=63c48de63becdee680e90cb2363984c2f8f77fd1

The second problem is that when the modesetting driver is being configured, a crash occurs, apparently because the PreInit function pointer is NULL. I don't know any more details than that.

When the first problem is fixed by applying the linked patch, X -configure does produce a working configure file for me with the QXL driver.

So I am moving this bug to the X server component and suggest applying the patch above to RHEL 6.

It may or may not be interesting to fix whatever is going on in the modesetting driver that makes it crash.
Comment 10 errata-xmlrpc 2014-10-14 00:52:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1376.html

Note You need to log in before you can comment on or make changes to this bug.