Bug 1001767 - Negative downloading speed in yum
Negative downloading speed in yum
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 13:17 EDT by Roman
Modified: 2013-09-29 20:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-urlgrabber-3.9.1-32.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 20:42:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman 2013-08-27 13:17:15 EDT
Description of problem:

Sometimes yum shows negative downloading speed.

Version-Release number of selected component (if applicable):

3.4.3-104.fc19

How reproducible:

I don't know guaranteed way to reproduce it, but from what I noticed it is more likely to get it on slow/laggy connections. The most of times I observed it were when I used EvDO/CDMA connection (maximal speed - 3.1 Mbits/s, actual speed varies hugely depending on signal strength and weather on Mars). With my fast 25 Mbit/s connection, it is very rare thing but I still saw it a few times.


Steps to Reproduce:
1. Connect to slow Internet (recommended, but can occur with fast one too)
2. yum update (or yum install a-lot-of-huge-things)
3. Wait and watch... Wait and watch...
4. And then it will happen. Or not. Usually it lasts only a few seconds, but sometimes yum drops connection with mirror because of it (more than 60 seconds with speed <1000b/s)

Actual results:

Negative downloading speed.

Expected results:

Actual or at least positive downloading speed.

Additional info:

...
Comment 1 Zdeněk Pavlas 2013-08-28 03:24:28 EDT
I'll look at the rate estimator code if there's some obvious bug. It does simple temporal averaging and if every partial input is >=0 the output should never be negative.  Probably the input to the estimator was garbage (negative size or time deltas).

> but sometimes yum drops connection with mirror because of it (more than 60 seconds with speed <1000b/s)

That's unrelated. The displayed download speed is UI thing *only*.  Yum does not close the connection, curl does (it does no averaging, speed has to be below the limit for the whole period). If you don't want this, set "minrate=100" or so in yum.conf
Comment 2 Fedora Update System 2013-09-27 08:07:07 EDT
python-urlgrabber-3.9.1-32.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.9.1-32.fc19
Comment 3 Fedora Update System 2013-09-27 20:18:05 EDT
Package python-urlgrabber-3.9.1-32.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-urlgrabber-3.9.1-32.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17817/python-urlgrabber-3.9.1-32.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-09-29 20:42:29 EDT
python-urlgrabber-3.9.1-32.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.