Bug 1001785 - install scriptlet failed
install scriptlet failed
Status: CLOSED DUPLICATE of bug 995158
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
: 1012713 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 14:33 EDT by charles.unix.pro
Modified: 2013-09-27 05:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 08:01:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles.unix.pro 2013-08-27 14:33:30 EDT
Description of problem:

yum update of acpid from acpid.x86_64 0:2.0.19-5.fc19 to acpid.x86_64 0:2.0.19-6.fc19 produced:

    /var/tmp/rpm-tmp.5g35cv: line 1: fg: no job control
    error: %preun(acpid-2.0.19-5.fc19.x86_64) scriptlet failed, exit status 1
    Error in PREUN scriptlet in rpm package acpid-2.0.19-5.fc19.x86_64

Version-Release number of selected component (if applicable):

 acpid-2.0.19-5.fc19.x86_64

How reproducible:


Steps to Reproduce:
1. update acpid from acpid.x86_64 0:2.0.19-5.fc19 to acpid.x86_64 0:2.0.19-6.fc19
2.
3.

Actual results:

    /var/tmp/rpm-tmp.5g35cv: line 1: fg: no job control
    error: %preun(acpid-2.0.19-5.fc19.x86_64) scriptlet failed, exit status 1
    Error in PREUN scriptlet in rpm package acpid-2.0.19-5.fc19.x86_64


Expected results:

  No errors

Additional info:
Comment 1 Jan "Yenya" Kasprzak 2013-08-28 04:26:24 EDT
This is probably not a bug in acpid, but in the RPM infrastructure. I have seen this bug today for acpid (the same versions as above), and also for nscd-2.17-13.fc19.x86_64 -> nscd-2.17-14.fc19.x86_64 update (with the same error message). Their %preun scripts are both the same: 

%systemd_preun nscd.service

So this is probably a RPM bug instead.
Comment 2 Andrew Travneff 2013-08-28 04:39:18 EDT
I have both acpid and nscd issues.

acpid: https://bugzilla.redhat.com/show_bug.cgi?id=995158 (solved?)

nscd:

/var/tmp/rpm-tmp.T5RYmW: line 1: fg: no job control
error: %preun(nscd-2.17-13.fc19.x86_64) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package nscd-2.17-13.fc19.x86_64
error: nscd-2.17-13.fc19.x86_64: erase failed

Updating nscd-2.17-13.fc19.x86_64 -> nscd-2.17-14.fc19.x86_64

RPM version: rpm-4.11.1-1.fc19.x86_64
Comment 3 Jaroslav Škarvada 2013-08-28 08:01:02 EDT
Sorry for the inconvenience, you need to use:

# rpm -e --noscripts acpid-2.0.19-5

to get rid of the acpid-2.0.19-5. Somebody changed something in the build system and the results is that the systemd with the rpm macros wasn't pulled in during the rebuild. So several packages using the systemd macros started to fail in the pre/post phases if they were rebuild after the change. The acpid-2.0.19-6 fixes the requires, but there is no way how to fix it in the acpid-2.0.19-5. You need to uninstall it manually.

*** This bug has been marked as a duplicate of bug 995158 ***
Comment 4 Jaroslav Škarvada 2013-09-27 05:02:19 EDT
*** Bug 1012713 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.