Bug 1001807 - FEAT: hwcert-client should indicate why it hasn't defaulted a plan item that is present
FEAT: hwcert-client should indicate why it hasn't defaulted a plan item that ...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1001233
  Show dependency treegraph
 
Reported: 2013-08-27 15:43 EDT by Rob Landry
Modified: 2013-11-13 04:57 EST (History)
4 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5 R12
Doc Type: Enhancement
Doc Text:
Feature: The hwcert command now provides more feedback when a test is being skipped, marking "pp" to the left of the text name when a test is skipped because it previously passed.
Story Points: ---
Clone Of:
: 1001831 1002768 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:57:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 2013-08-27 15:43:43 EDT
Description of problem:

Currently hwcert-client doesn't plan tests it doesn't need, and this is correct however it leaves it as an exercise for the user to determine why it doesn't think it needs to test something.  It would be helpful if it provided some indicator that a test was skipped for what reason.  This way it would be more clear that it isn't a basic hardware detection issue.
Comment 1 Greg Nichols 2013-09-24 21:11:55 EDT
committed to R12
Comment 5 Brian Brock 2013-10-09 11:15:45 EDT
verified in -22.el6
Comment 7 errata-xmlrpc 2013-11-13 04:57:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.