Bug 1001869 - suitesparse-devel is missing c++ headers
Summary: suitesparse-devel is missing c++ headers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: suitesparse
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Tomas Tomecek
QA Contact: Jan Kepler
URL:
Whiteboard:
Depends On:
Blocks: 1001943 1010368
TreeView+ depends on / blocked
 
Reported: 2013-08-28 02:36 UTC by Brian Pitts
Modified: 2014-03-26 09:05 UTC (History)
4 users (show)

Fixed In Version: suitesparse-3.4.0-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1001943 (view as bug list)
Environment:
Last Closed: 2014-03-17 08:41:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0296 normal SHIPPED_LIVE suitesparse bug fix update 2014-03-17 12:40:49 UTC

Description Brian Pitts 2013-08-28 02:36:04 UTC
Description of problem:

The suitesparse-devel package does not include the C++ header files.

Version-Release number of selected component (if applicable):

Tested with suitesparse 3.4.0-7.el6 

How reproducible:

Always

Steps to Reproduce:
$ repoquery --list suitesparse-devel | grep hpp

Actual results:

Nothing is found.

Expected results:

I expect to find the hpp files from the source.

$ wget --quiet 'https://www.cise.ufl.edu/research/sparse/SuiteSparse/SuiteSparse-3.4.0.tar.gz'
$ tar tf SuiteSparse-3.4.0.tar.gz | grep hpp
SuiteSparse/SPQR/MATLAB/spqr_mx.hpp
SuiteSparse/SPQR/Include/SuiteSparseQR.hpp
SuiteSparse/SPQR/Include/spqr.hpp


Additional info:

Without SuiteSparseQR.hpp you cannot compile https://code.google.com/p/ceres-solver/

Comment 1 Tomas Tomecek 2013-08-28 08:18:11 UTC
Thank you for bugreport, Brian.

The bug occurs in spec file: files with suffix 'hpp' are not being copied to %{_includedir} which is a mistake.

This patch should fix it:

diff --git a/suitesparse.spec b/suitesparse.spec
index 770f727..b5b52c1 100644
--- a/suitesparse.spec
+++ b/suitesparse.spec
@@ -337,7 +337,7 @@ pushd Lib
   done
 popd
 pushd Include
-  for f in *.h;  do
+  for f in *.h*;  do
     cp -a $f ${RPM_BUILD_ROOT}%{_includedir}/%{name}/$f
   done
 popd

Comment 3 Tomas Tomecek 2014-03-10 16:11:16 UTC
$ rpm -ql -p suitesparse-devel-3.4.0-9.el6.x86_64.rpm | grep hpp
/usr/include/suitesparse/SuiteSparseQR.hpp
/usr/include/suitesparse/spqr.hpp

Comment 8 errata-xmlrpc 2014-03-17 08:41:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0296.html


Note You need to log in before you can comment on or make changes to this bug.