Bug 1001888 - AttributeError: 'NoneType' object has no attribute 'startswith'
AttributeError: 'NoneType' object has no attribute 'startswith'
Status: CLOSED DUPLICATE of bug 1000715
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:4d95e5db485a0e03aa47b82a9a5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 00:04 EDT by Shawn Starr
Modified: 2013-08-28 00:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 00:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (296.94 KB, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: anaconda.log (7.65 KB, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: environ (490 bytes, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: ks.cfg (1.31 KB, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: lsblk_output (948 bytes, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: os_info (281 bytes, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: program.log (12.44 KB, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: storage.log (39.96 KB, text/plain)
2013-08-28 00:04 EDT, Shawn Starr
no flags Details
File: syslog (63.19 KB, text/plain)
2013-08-28 00:05 EDT, Shawn Starr
no flags Details
File: ifcfg.log (398 bytes, text/plain)
2013-08-28 00:05 EDT, Shawn Starr
no flags Details
File: packaging.log (27.43 KB, text/plain)
2013-08-28 00:05 EDT, Shawn Starr
no flags Details

  None (edit)
Description Shawn Starr 2013-08-28 00:04:22 EDT
Description of problem:
PXE installation with a kickstart:

PXE boot parameters to initramfs:  append initrd=initrd-x86_64.img ip=dhcp ks=ftp://172.18.2.4/ks.cfg inst.stage2=ftp://172.18.2.4/os-x86_64 slub_debug=

kickstart:

rootpw letmein
install
#url --url http://172.18.2.3/fedora

#ftp --server=192.168.10.1
#nfs --server=172.18.2.4 --dir=/var/lib/libvirt/images
lang en_US.UTF-8
#network --device eth0 --bootproto static
# --bootproto dhcp
selinux --disabled

%pre
%end

firewall --disabled
authconfig --enableshadow --enablemd5
#keyboard 'us'
timezone --utc America/Toronto
zerombr
clearpart --all --drives=vda
part /boot --fstype ext2 --size=300 --asprimary
part / --fstype ext2 --grow --size=1024 --asprimary
bootloader --location=mbr --driveorder=vda --timeout=5

%packages --nobase --excludedocs
@Standard
kernel
grub2
-sendmail
net-tools
chrony
%end

%post --log=/root/dump.log
echo "Disabling services: mcelog, smartd, firewalld, atd, crond"
chkconfig mcelog off
chkconfig smartd off
chkconfig firewalld off
chkconfig atd off
chkconfig crond off
chkconfig chronyd on

echo "1 letmein" >> /etc/chrony.keys
%end

Set the keyboard to US manually, then tried to select installation source, Anaconda crashed.

Version-Release number of selected component:
anaconda-20.8-1

The following was filed automatically by anaconda:
anaconda 20.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 651, in refresh
    if proto.startswith("http:"):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 413, in _on_spoke_clicked
    self._runSpoke(spoke)
AttributeError: 'NoneType' object has no attribute 'startswith'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd-x86_64.img ip=dhcp ks=ftp://172.18.2.4/ks.cfg inst.stage2=ftp://172.18.2.4/os-x86_64 slub_debug=- BOOT_IMAGE=vmlinuz-x86_64 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC1
Comment 1 Shawn Starr 2013-08-28 00:04:28 EDT
Created attachment 791237 [details]
File: anaconda-tb
Comment 2 Shawn Starr 2013-08-28 00:04:34 EDT
Created attachment 791238 [details]
File: anaconda.log
Comment 3 Shawn Starr 2013-08-28 00:04:38 EDT
Created attachment 791239 [details]
File: environ
Comment 4 Shawn Starr 2013-08-28 00:04:41 EDT
Created attachment 791240 [details]
File: ks.cfg
Comment 5 Shawn Starr 2013-08-28 00:04:44 EDT
Created attachment 791241 [details]
File: lsblk_output
Comment 6 Shawn Starr 2013-08-28 00:04:48 EDT
Created attachment 791242 [details]
File: nmcli_dev_list
Comment 7 Shawn Starr 2013-08-28 00:04:52 EDT
Created attachment 791243 [details]
File: os_info
Comment 8 Shawn Starr 2013-08-28 00:04:55 EDT
Created attachment 791244 [details]
File: program.log
Comment 9 Shawn Starr 2013-08-28 00:04:59 EDT
Created attachment 791245 [details]
File: storage.log
Comment 10 Shawn Starr 2013-08-28 00:05:04 EDT
Created attachment 791246 [details]
File: syslog
Comment 11 Shawn Starr 2013-08-28 00:05:08 EDT
Created attachment 791247 [details]
File: ifcfg.log
Comment 12 Shawn Starr 2013-08-28 00:05:12 EDT
Created attachment 791248 [details]
File: packaging.log
Comment 13 Shawn Starr 2013-08-28 00:23:26 EDT
Due to blocker bug this may not be reliable, if I reproduce the blocker bug for hostname is fixed, then create new bug
Comment 14 John Dulaney 2013-08-28 00:24:27 EDT

*** This bug has been marked as a duplicate of bug 1000715 ***

Note You need to log in before you can comment on or make changes to this bug.