Bug 1001898 - unset "grp:alt_shift_toggle" when removing second keyboard layout
unset "grp:alt_shift_toggle" when removing second keyboard layout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 01:12 EDT by Jens Petersen
Modified: 2014-01-27 16:20 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-27 16:20:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2013-08-28 01:12:57 EDT
Description of problem:
This might be anaconda's fault perhaps - I am not sure
but /etc/X11/xorg.conf.d/00-keyboard.conf is owned by systemd
so filing against it initially.

If only one keyboard layout is defined then 00-keyboard.conf
should not include option "grp:alt_shift_toggle" which
is only useful when more than one layout is listed.

How reproducible:
100%

Steps to Reproduce:
1. install Fedora in some language other than English perhaps
   (not sure if language matters), selecting only US keyboard layout.
2. Boot to dm and login to X session
3. Try to use Alt+Shift modifier.

Actual results:
3. doesn't work since it is grabbed by X server

Expected results:
3. Able to use Alt+Shift normally in X session.

Additional info:
GNOME ignores /etc/X11/xorg.conf.d/00-keyboard.conf completely
and does its own kbd settings so I think many people are quite
unaware of this bug.

It is true for all current Fedora releases.
Comment 1 Jens Petersen 2013-09-01 23:21:42 EDT
The more I think about it, I think this must be coming from anaconda.

Maybe the coming keyboard layout improvements coming to anaconda
might address this?  But I don't think anaconda should setup
Alt+Shift toggle when there is only one keyboard layout defined.
Comment 2 Jens Petersen 2013-09-02 00:21:20 EDT
I think this happens since for most languages currently one gets
US layout by default in addition to native layout.  But one then
removes US layout in the keyboard spoke the alt_shift_toggle remains.
If US layout was not added by default for most languages this
would probably be less of a problem.
Comment 3 David Shea 2014-01-27 16:20:02 EST
I think that this bug can be closed based on the new anaconda behavior. grp:alt_shift_toggle is still set if more than one layout is configured by the selections on the welcome screen, but most locales now only configure one keyboard layout. The exceptions are languages using non-Latin characters, the assumption there being that the user will always need another layout in order to type English-based commands and such.

So the problem you describe still exists in the sense that if you start with two layouts and remove one, the layout switch shortcut will still be in effect if not also manually removed (under the Options dialog on the keyboard spoke), but I think that it's now unlikely that a user will end up in a situation where grp:alt_shift_toggle is set unexpectedly.

Note You need to log in before you can comment on or make changes to this bug.