Bug 1001934 - 15 sec timeout when mounting with nfs4
15 sec timeout when mounting with nfs4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 03:30 EDT by marcindulak
Modified: 2014-03-02 04:12 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 10:06:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description marcindulak 2013-08-28 03:30:36 EDT
Description of problem:

With the default nfs-utils configuration on Fedora 19,
a mount takes 15 sec delay.
This may be a simple configuration issue but I didn't find any relevant documentation. The problem is present also on Rawhide.

Version-Release number of selected component (if applicable):

nfs-utils-1.2.8-3.0.fc19.i686
kernel-PAE-3.10.9-200.fc19.i686
systemd-204-9.fc19.i686

How reproducible:


Steps to Reproduce:

1. yum -y remove nfs-utils; yum -y install nfs-utils
2. systemctl stop firewalld.service&& setenforce 0
3. echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
4. echo 1 > /proc/sys/net/ipv6/conf/default/disable_ipv6
5. echo "/opt localhost(rw)" > /etc/exports
6. exportfs -rav
7. mkdir /root/opt
8. time mount -vt nfs localhost:/opt /root/opt -overs=4

Actual results:

mount.nfs: timeout set for Tue Aug 27 XX:XX:XX 2013
mount.nfs: trying text-based options 'vers=4,addr=127.0.0.1,clientaddr=127.0.0.1'

real	0m15.021s
user	0m0.002s
sys	0m0.008s

In /var/log/messages

kernel: RPC: AUTH_GSS upcall timed out.
kernel: Please check user daemon is running.

Expected results:

mounts way below 1 sec.

Additional info:

The problem reported at https://ask.fedoraproject.org/question/30612/nfs-gss-problems-on-f19/
Possible workarounds:

1. start rpc.gssd on the client:

   systemctl enable nfs-secure.service
   systemctl start nfs-secure.service

   This results with "rpc.gssd: ERROR: gssd_refresh_krb5_machine_credential: no usable keytab entry found in keytab ..." in /var/log/messages

2. use -overs=3 when mounting from the client

3. blacklist the rpcsec_gss_krb5 module on the client:

   echo "blacklist rpcsec_gss_krb5" > /usr/lib/modprobe.d/dist-blacklist.conf
   reboot
Comment 1 marcindulak 2013-08-28 12:39:11 EDT
(In reply to marcindulak from comment #0)
> Description of problem:
> 
> With the default nfs-utils configuration on Fedora 19,
> a mount takes 15 sec delay.
> This may be a simple configuration issue but I didn't find any relevant
> documentation. The problem is present also on Rawhide.
> 
> Version-Release number of selected component (if applicable):
> 
> nfs-utils-1.2.8-3.0.fc19.i686
> kernel-PAE-3.10.9-200.fc19.i686
> systemd-204-9.fc19.i686
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 
> 1. yum -y remove nfs-utils; yum -y install nfs-utils
> 2. systemctl stop firewalld.service&& setenforce 0
> 3. echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
> 4. echo 1 > /proc/sys/net/ipv6/conf/default/disable_ipv6
> 5. echo "/opt localhost(rw)" > /etc/exports
> 6. exportfs -rav
> 7. mkdir /root/opt
> 8. time mount -vt nfs localhost:/opt /root/opt -overs=4
> 
> Actual results:
> 
> mount.nfs: timeout set for Tue Aug 27 XX:XX:XX 2013
> mount.nfs: trying text-based options
> 'vers=4,addr=127.0.0.1,clientaddr=127.0.0.1'
> 
> real	0m15.021s
> user	0m0.002s
> sys	0m0.008s
> 
> In /var/log/messages
> 
> kernel: RPC: AUTH_GSS upcall timed out.
> kernel: Please check user daemon is running.
> 
> Expected results:
> 
> mounts way below 1 sec.
> 
> Additional info:
> 
> The problem reported at
> https://ask.fedoraproject.org/question/30612/nfs-gss-problems-on-f19/
> Possible workarounds:
> 
> 1. start rpc.gssd on the client:
> 
>    systemctl enable nfs-secure.service
>    systemctl start nfs-secure.service
> 
>    This results with "rpc.gssd: ERROR: gssd_refresh_krb5_machine_credential:
> no usable keytab entry found in keytab ..." in /var/log/messages
> 
> 2. use -overs=3 when mounting from the client
> 
> 3. blacklist the rpcsec_gss_krb5 module on the client:
> 
>    echo "blacklist rpcsec_gss_krb5" > /usr/lib/modprobe.d/dist-blacklist.conf

echo "blacklist rpcsec_gss_krb5" >> /usr/lib/modprobe.d/dist-blacklist.conf

>    reboot
Comment 2 Timothée Ravier 2013-10-06 10:37:25 EDT
You should use /etc/modprobe.d/ for custom configurations:

echo "blacklist rpcsec_gss_krb5" > /etc/modprobe.d/blacklist-nfs-gss-krb5.conf
Comment 3 Kamil Páral 2013-11-12 06:36:34 EST
I can confirm exactly the same problem in Fedora 20. Mounting NFS shares takes 15 seconds and these messages are printed to journal:

> RPC: AUTH_GSS upcall timed out.
> Please check user daemon is running.

If I start rpcgssd.service, the mounts are instantaneous.

A lot of people are hit by this problem, see:
https://bbs.archlinux.org/viewtopic.php?pid=1312879
https://ask.fedoraproject.org/question/30612/nfs-gss-problems-on-f19/
http://joshuawise.com/kerberos-nfs
https://wiki.archlinux.org/index.php/NFS#Client
(or just google for that error message)
Comment 4 Jeff Layton 2013-11-12 08:40:10 EST
Upstream patch posting:

http://article.gmane.org/gmane.linux.nfs/59939
Comment 5 Jeff Layton 2013-11-15 08:29:56 EST
Revised upstream patch posting here:

http://article.gmane.org/gmane.linux.nfs/60081
Comment 6 Jeff Layton 2014-01-06 10:06:03 EST
Backported versions of these patches have been merged into f19 and f20 kernels, so this should no longer be a problem there. Please reopen if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.