Bug 1001950 - [RFE] same action on all ovirt-node-install page for press enter
[RFE] same action on all ovirt-node-install page for press enter
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.2
All All
low Severity low
: ---
: ---
Assigned To: Ryan Barry
bugs@ovirt.org
node
: FutureFeature
: 1003228 (view as bug list)
Depends On:
Blocks: 1003228
  Show dependency treegraph
 
Reported: 2013-08-28 03:59 EDT by bohai
Modified: 2014-07-14 07:23 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1003228 (view as bug list)
Environment:
Last Closed: 2014-07-14 07:23:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bohai 2013-08-28 03:59:35 EDT
Description of problem:
On the keyboard selection page of ovirt-node-installer, if you press enter, 
it will switch to next page.
But on the password and storage page, if you press enter, nothing will happen.
Whether it's better to make the action same on all page? 

Version-Release number of selected component (if applicable):
Latest

How reproducible:
100%

Steps to Reproduce:
1.enter ovirt-node-installer page
2.switch to password config page
3.press enter

Actual results:
enter the next page

Expected results:
Nothing to do

Additional info:
None
Comment 1 Mike Burns 2013-08-30 09:18:54 EDT
Probably a node 3.1 target
Comment 2 Itamar Heim 2014-02-13 13:31:02 EST
pushing to target release 3.5, assuming its not planned for 3.4 at this point...
Comment 3 Itamar Heim 2014-06-29 04:40:27 EDT
*** Bug 1003228 has been marked as a duplicate of this bug. ***
Comment 4 Fabian Deutsch 2014-07-14 07:23:03 EDT
I would say this is not a bug, because:

1. On the keyboard page there is only one entry item (the table with the available layouts). If the user hits return then it is clear that the user selected an entry in the table, and because that is the only input element on that page the installer can continue to the next page.

2. The storage and password pages contain more than one input element, thus hitting return will not lead to the next page, because the user needs to input more than one bit of information.

That is the reason why i see this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.