Bug 1001979 - satellite-sync --master option not documented in man-page
satellite-sync --master option not documented in man-page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Pavel Studeník
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-28 04:57 EDT by Jan Hutař
Modified: 2013-10-01 17:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-backend-2.0.3-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-08-28 04:57:24 EDT
Description of problem:
satellite-sync "--master" option not documented in man-page


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-2.0.3-10.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. # man satellite-sync
2. Search for "--master"


Actual results:
It is not documented there.


Expected results:
It should be explained there. Is should mention in which cases you want to use that and so on.


Additional info:
I consider this important (and safe) for Sat560 release.
Comment 1 Michael Mráka 2013-08-28 08:11:50 EDT
Fixed in spacewalk master by
commit f06f38ac32096ce623e5258fa2ca78e5e5698315
    1001979 - fixed man page
Comment 2 Michael Mráka 2013-08-28 08:18:31 EDT
Backported to SATELLITE-5.6 as
commit 3e1f57bb6d04739b3f7cfcf2281b3881656909bf
    1001979 - fixed man page
Comment 4 Pavel Studeník 2013-09-03 08:51:40 EDT
package: spacewalk-backend-2.0.3-12.el6sat.noarch

>> man satellite-sync
...
 --master
              the  fully qualified doman name of the master Satellite. Valid with --mount-point only. Required if you want to import org data and channel per-
              missions.
...

Type error: "doman name" => "domain name" (FQDM - Fully Qualified Domain Name)
Comment 5 Michael Mráka 2013-09-06 04:45:43 EDT
Typo fixed in spacewalk master by
commit c81f0e667578aca173abafd2b55fe780d57a405d
    1001979 - fixed typo in --master description
Comment 6 Michael Mráka 2013-09-06 04:49:05 EDT
Backported to SATELLITE-5.6 as
commit b3b008e3d0a7c2b250c2faf382d51d29816a515a
    1001979 - fixed typo in --master description
Comment 9 Clifford Perry 2013-10-01 17:54:18 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.