Bug 1001989 - Could not start arquillian container on IPV6 Windows Oracle JDK6 due to java.net.SocketException: Address family not supported by protocol family: bind
Could not start arquillian container on IPV6 Windows Oracle JDK6 due to java....
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: IPv6 support (Show other bugs)
6.1.1,6.2.0,6.2.1,6.3.0,6.2.2,6.2.3,6.2.4
Unspecified Windows
unspecified Severity high
: ---
: ---
Assigned To: Petr Kremensky
Petr Kremensky
Russell Dickenson
https://issues.jboss.org/browse/JBPAP...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 05:24 EDT by Pavel Jelinek
Modified: 2015-02-20 06:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-01 03:05:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-8881 Major Resolved Could not start arquillian container on IPV6 Windows Oracle JDK6 due to java.net.SocketException: Address family not su... 2016-02-17 06:36 EST

  None (edit)
Description Pavel Jelinek 2013-08-28 05:24:09 EDT
All tests in EAP AS Testsuite using arquillian fail.

Stacktrace: 

Caused by: java.net.SocketException: Address family not supported by protocol family: bind
	at sun.nio.ch.Net.bind(Native Method) [rt.jar:1.6.0_45]
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:124) [rt.jar:1.6.0_45]
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59) [rt.jar:1.6.0_45]
	at org.jboss.sun.net.httpserver.ServerImpl.<init>(ServerImpl.java:144)
	at org.jboss.sun.net.httpserver.HttpServerImpl.<init>(HttpServerImpl.java:54)
	at org.jboss.sun.net.httpserver.DefaultHttpServerProvider.createHttpServer(DefaultHttpServerProvider.java:38)
	at org.jboss.com.sun.net.httpserver.HttpServer.create(HttpServer.java:147)
	at org.jboss.as.domain.http.server.ManagementHttpServer.create(ManagementHttpServer.java:162)
	at org.jboss.as.server.mgmt.HttpManagementService.start(HttpManagementService.java:190) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
Comment 1 Brian Stansberry 2014-06-30 18:40:12 EDT
Should this be closed? AIUI it is not our bug.
Comment 2 Pavel Jelinek 2014-07-01 03:05:24 EDT
It's known issue of OracleJDK 1.6 on Windows so it can't be fixed in EAP. 
See: https://issues.jboss.org/browse/JBPAPP-9281?focusedCommentId=12699813&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12699813

Note You need to log in before you can comment on or make changes to this bug.