Bug 1001990 - Drools 6 sample project can't be run
Drools 6 sample project can't be run
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Eclipse Tooling (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Kris Verlaenen
Tomas Schlosser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 05:24 EDT by Tomas Schlosser
Modified: 2014-08-06 16:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:15:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Schlosser 2013-08-28 05:24:32 EDT
Description of problem:
If you create a project with all samples for Drools 6 and try to run the sample classes, you get build errors.

Version-Release number of selected component (if applicable):
BRMS 6.0.0.ER2
JBoss Drools Core 6.0.0.201308222359 org.drools.eclipse.feature.feature.group

How reproducible:


Steps to Reproduce:
1. create new Drools 6 project with all samples
2. run DroolsTest class

Actual results:
java.lang.RuntimeException: Error while creating KieBase

Expected results:
Rules run fine and print the correct output.

Additional info:
The problem is that Sample.xls and Sample.drl use the Message class, but both files use their own definition. This was not problem prior to 6 version, but things changed in Drools 6. Now both files are included in one KieBase, where imports are merged, thus thic conflict.
I see two solutions to this problem:
1) create a common class Message that both rulesets will use
2) modify kmodule.xml to include only packages relevant to the type of KieBase (e.g. for 'rules' KieBase, add attribute 'packages="rules"')
Comment 4 Tomas Schlosser 2014-01-15 06:30:50 EST
Verified with Drools plugin 6.0.1.Final

Note You need to log in before you can comment on or make changes to this bug.