Bug 1001996 - Getting ugly output on remote-viewer window because gtk and xorg-x11-font* libraries are missing.
Getting ugly output on remote-viewer window because gtk and xorg-x11-font* li...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk2 (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: 6.5
Assigned To: Benjamin Otte
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 05:40 EDT by Leonid Natapov
Modified: 2017-12-06 07:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:40:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2013-08-28 05:40:40 EDT
Getting ugly output on remote-viewer window because gtk and xorg-x11-font* libraries are missing. 

When trying to run remote-viewer in order to connect to VM getting the following error message:
[root@dhcp-3-156 ~]# /usr/bin/remote-viewer vnc://localhost:5900

Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
(remote-viewer:17148): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'


The window opens but as said in the message the output is ugly. Garbage instead of fonts. The problem was solved after manually installing  PackageKit-gtk-module, libcanberra-gtk2, xorg-x11-font*.

We need to include this in installation or inform user to install it in order to be able see correct fonts when running remote-viewer and other gtk applications.
Comment 1 Itamar Heim 2013-08-29 02:23:06 EDT
if remote-viewer needs this to function properly, i expect this to be a dependency of remote-viewer.
Comment 2 Christophe Fergeau 2013-08-29 05:28:47 EDT
And since it's not just remote-viewer but any gtk application that has this fontissue, this should be solved down the stack, not in remote-viewer. Moving to gtk+, but that's quite a random guess.
Comment 3 RHEL Product and Program Management 2013-10-13 22:31:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Jan Kurik 2017-12-06 07:40:59 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.