Bug 1001997 - MonitoringScout EXECUTION FAILED: Can't open config file '/usr/share/rhn/config-defaults/rhn_web.conf'
MonitoringScout EXECUTION FAILED: Can't open config file '/usr/share/rhn/conf...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Lukas Pramuk
:
Depends On:
Blocks: sat560-blockers sat560-proxy
  Show dependency treegraph
 
Reported: 2013-08-28 05:43 EDT by Lukas Pramuk
Modified: 2013-10-01 15:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: spacewalk-proxy-2.0.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 15:40:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Pramuk 2013-08-28 05:43:37 EDT
Description of problem:
MonitoringScout execution failed due to missing config file '/usr/share/rhn/config-defaults/rhn_web.conf'

Version-Release number of selected component (if applicable):
RHN-Proxy-5.6.0-RHEL6-re20130828.0

How reproducible:
inevitably

Steps to Reproduce:
1. Install proxy against parent that has monitoring activated 
2. During proxy installation enable MonitoringScout (proceed using defaults)
3. At the end of installation, upon rhn-proxy restart tuple error message displayed
Enabling Spacewalk Proxy.
Shutting down rhn-proxy...
2013-08-28 05:16:36 !!!!!!!!!! STEP MonitoringScout EXECUTION FAILED: Can't open config file '/usr/share/rhn/config-defaults/rhn_web.conf': No such file or directory at /usr/share/perl5/vendor_perl/PXT/Config.pm line 71.

Terminating jabberd processes ...
Stopping s2s:                                              [FAILED]
Stopping c2s:                                              [FAILED]
Stopping sm:                                               [FAILED]
Stopping router:                                           [FAILED]
Stopping httpd:                                            [FAILED]
Stopping squid:                                            [FAILED]
Done.
Starting rhn-proxy...
init_cache_dir /var/spool/squid... Starting squid: .       [  OK  ]
Starting httpd:                                            [  OK  ]
Initializing jabberd processes ...
Starting router:                                           [  OK  ]
Starting sm:                                               [  OK  ]
Starting c2s:                                              [  OK  ]
Starting s2s:                                              [  OK  ]
Starting MonitoringScout ...  
2013-08-28 05:16:45 !!!!!!!!!! STEP MonitoringScout EXECUTION FAILED: Can't open config file '/usr/share/rhn/config-defaults/rhn_web.conf': No such file or directory at /usr/share/perl5/vendor_perl/PXT/Config.pm line 71.

Done.

4. Afterwards error message is printed during rhn-proxy start | stop | restart | status 

Actual results:
MonitoringScout execution fails

Expected results:
MonitoringScout execution succeeds

Additional info:
/usr/share/rhn/config-defaults/rhn_web.conf is provided by spacewalk-base-minimal-config. So it can be easily workarounded by yum install spacewalk-base-minimal-config.
Some package should require spacewalk-base-minimal-config to be installed in order to avoid this execution fail.
Comment 2 Tomas Lestach 2013-08-28 07:41:28 EDT
adding missing Require ...

spacewalk.git: 5ee39bbe486475d99943e8147259876d1035b913
Comment 4 Tomas Lestach 2013-08-28 08:05:19 EDT
Hmm, it looks we do not want spacewalk-base-minimal to require spacewalk-base-minimal-config due to managed-db

reverting ...
spacewalk.git: ec2ae9f0360a551fdb09b7c247de7a3d34f79a13

Adding the Require to spacewalk-proxy-management ...
spacewalk.git: 33095300922667d7a5af99fbfcb011628a74b41d
Comment 8 Clifford Perry 2013-10-01 15:40:05 EDT
Red Hat Satellite Proxy 5.6 has been released. This bug tracked under Proxy. 

This bug either was VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:



Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1392.html

Note You need to log in before you can comment on or make changes to this bug.