Bug 1002032 - mke2fs can't return the correct filesystem type when blockscount is less than 2048 for ext3
mke2fs can't return the correct filesystem type when blockscount is less than...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 07:12 EDT by bfan
Modified: 2014-06-17 22:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: libguestfs-1.22.6-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:57:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bfan 2013-08-28 07:12:45 EDT
Description of problem:
For creating ext3 filesystem, When "blockscount" option is less than 2048, mke2fs will create a ext2 filesystem
It looks like an ext3 filesystem issue, we can't know the details reason of ext3/mke2fs, So if we can do nothing in libguestfs, it would be better to add a note to the documentation


Version-Release number of selected component (if applicable):
libguestfs-1.22.6-4.el7.x86_64


How reproducible:
Always


Steps to Reproduce:
# guestfish -N fs mke2fs /dev/sda1 fstype:ext3 blockscount:2048 : list-filesystems
/dev/sda1: ext3
# guestfish -N fs mke2fs /dev/sda1 fstype:ext3 blockscount:2049 : list-filesystems
/dev/sda1: ext3
# guestfish -N fs mke2fs /dev/sda1 fstype:ext3 blockscount:2047 : list-filesystems
/dev/sda1: ext2


Actual results:
Output is ext2 when fstype:ext3 blockscount:2047


Expected results:
Output should be ext3 when fstype:ext3 blockscount:2047


Additional info:
Has same issue in rhel6, libguestfs-1.20.10-3.el6.x86_64
Comment 1 Richard W.M. Jones 2013-08-28 07:42:22 EDT
As discussed on IRC, the problem is that the filesystem
isn't large enough to contain a journal.  mke2fs prints
the warning message:

  Filesystem too small for a journal

This message is normally eaten by libguestfs, although
you can see it if you enable debugging.  The warning
doesn't stop mke2fs; it goes ahead and creates a filesystem
without a journal, a.k.a. ext2.

Anyway, we should document that this may happen.

BTW don't confuse "blockscount" (size of the filesystem
in blocks) with block size.
Comment 3 Richard W.M. Jones 2013-08-29 10:22:47 EDT
Fix also included in libguestfs-1.20.10-4.el6 (note
there is no separate bug for RHEL 6, I just included
the fix in the routine build).
Comment 5 bfan 2013-12-03 04:26:11 EST
Verified with libguestfs-1.22.6-16.el7.x86_64

><fs> help mke2fs

DESCRIPTION
    "mke2fs" is used to create an ext2, ext3, or ext4 filesystem on
    "device".

    The optional "blockscount" is the size of the filesystem in blocks. If
    omitted it defaults to the size of "device". Note if the filesystem is
    too small to contain a journal, "mke2fs" will silently create an ext2
    filesystem instead.


Help out is update
Comment 6 Ludek Smid 2014-06-13 08:57:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.