Bug 1002035 - avc: denied { create } for pid=632 comm="systemd-tmpfile" name="tmp" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir
avc: denied { create } for pid=632 comm="systemd-tmpfile" name="tmp" scont...
Status: CLOSED DUPLICATE of bug 1002059
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 07:20 EDT by Steve Tyler
Modified: 2013-08-29 02:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 15:27:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2013-08-28 07:20:20 EDT
Description of problem:
Three comm="systemd-tmpfile" avcs appear in the syslog for Bug 1001425, Attachment 791262 [details]:

16:29:53,475 NOTICE kernel:[  191.095199] type=1400 audit(1377620992.378:3): avc:  denied  { create } for  pid=632 comm="systemd-tmpfile" name="tmp" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
Bug 1001425: (This is for the F20 Alpha TC1 DVD.)
selinux-policy-3.12.1-72.fc20.noarch (per attached packaging.log)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2013-08-28 15:27:12 EDT
Did you remove the /var/tmp directory?

mkdir /var/tmp
restorecon /var/tmp

Should fix the problem
Comment 2 Steve Tyler 2013-08-28 15:43:46 EDT
This was on the installer DVD. I filed this before I tried a reproducer.

This bug has more details:
Bug 1002059 - avc: denied messages in syslog after booting Fedora-20-Alpha-TC1-x86_64-DVD.iso
Comment 3 Steve Tyler 2013-08-28 15:49:51 EDT
(In reply to Daniel Walsh from comment #1)
> Did you remove the /var/tmp directory?
> 
> mkdir /var/tmp
> restorecon /var/tmp
> 
> Should fix the problem

Shouldn't that be done when the installer DVD is composed?
Comment 4 Daniel Walsh 2013-08-28 16:20:26 EDT
Yes the /var/tmp directory should exist and be labeled correctly.
Comment 5 Steve Tyler 2013-08-29 02:33:27 EDT

*** This bug has been marked as a duplicate of bug 1002059 ***

Note You need to log in before you can comment on or make changes to this bug.