Bug 1002077 - anaconda ppc64 fails with "script error with package [various package names]"
Summary: anaconda ppc64 fails with "script error with package [various package names]"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 20
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1045384 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-28 12:54 UTC by Richard W.M. Jones
Modified: 2014-01-23 11:36 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-02 17:25:35 UTC


Attachments (Terms of Use)
anaconda.log (12.89 KB, text/plain)
2013-08-28 12:54 UTC, Richard W.M. Jones
no flags Details
anaconda-yum.log (269 bytes, text/plain)
2013-08-28 12:54 UTC, Richard W.M. Jones
no flags Details
ifcfg.log (486 bytes, text/plain)
2013-08-28 12:55 UTC, Richard W.M. Jones
no flags Details
packaging.log (255.29 KB, text/plain)
2013-08-28 12:56 UTC, Richard W.M. Jones
no flags Details
program.log (32.00 KB, text/plain)
2013-08-28 12:56 UTC, Richard W.M. Jones
no flags Details
storage.log (140.05 KB, text/plain)
2013-08-28 12:57 UTC, Richard W.M. Jones
no flags Details
storage.state (80.00 KB, text/plain)
2013-08-28 12:57 UTC, Richard W.M. Jones
no flags Details
syslog (61.37 KB, text/plain)
2013-08-28 12:58 UTC, Richard W.M. Jones
no flags Details
yum transaction file (11.76 KB, application/x-bzip)
2013-12-20 09:16 UTC, František Dvořák
no flags Details
log files from installation of Fedora 20 PPC64 under qemu (71.48 KB, application/x-bzip)
2013-12-22 21:38 UTC, František Dvořák
no flags Details

Description Richard W.M. Jones 2013-08-28 12:54:01 UTC
Description of problem:

Anaconda install fails with:

Error

The following error occurred while installing.  This is a fatal error
and installation will be aborted.

 script error with package [pinentry|ca-certificates]
Press enter to exit.

The package name printed depends on the mix of packages you're
trying to install, but so far I have seen "pinentry" and
"ca-certificates".

There is no other indication about why the script may have
failed.  No error appears on screen or in any log file as
far as I can find.

Why are script errors fatal?

Version-Release number of selected component (if applicable):

Anaconda in Fedora 19 ppc64.

How reproducible:

100%

Steps to Reproduce:
1. Do a minimal, text install.

Additional info:

Will attach log files.

Comment 1 Richard W.M. Jones 2013-08-28 12:54:33 UTC
Created attachment 791384 [details]
anaconda.log

Comment 2 Richard W.M. Jones 2013-08-28 12:54:57 UTC
Created attachment 791385 [details]
anaconda-yum.log

Comment 3 Richard W.M. Jones 2013-08-28 12:55:32 UTC
Created attachment 791386 [details]
ifcfg.log

Comment 4 Richard W.M. Jones 2013-08-28 12:56:09 UTC
Created attachment 791387 [details]
packaging.log

Comment 5 Richard W.M. Jones 2013-08-28 12:56:38 UTC
Created attachment 791388 [details]
program.log

Comment 6 Richard W.M. Jones 2013-08-28 12:57:21 UTC
Created attachment 791389 [details]
storage.log

Comment 7 Richard W.M. Jones 2013-08-28 12:57:46 UTC
Created attachment 791390 [details]
storage.state

Comment 8 Richard W.M. Jones 2013-08-28 12:58:18 UTC
Created attachment 791391 [details]
syslog

Comment 9 David Shea 2013-09-03 21:56:55 UTC
The script errors are fatal because yum is indicating that the script errors are fatal to the transaction. In the ca-certificates case in the attached, the failure is in %pre, so the package is indicating there's something wrong with the system that prevents the package from being installed.

I'm not able to reproduce doing a minimal text install to an LPAR, so I'm not sure whether there's a problem with the ca-certificates or pinentry packages or not. Maybe it's a hardware problem?

Comment 10 František Dvořák 2013-12-20 09:16:33 UTC
Created attachment 839473 [details]
yum transaction file

Comment 11 František Dvořák 2013-12-20 09:19:32 UTC
I can confirm with Fedora 20 graphical installer running under qemu-system-ppc64. I also have used minimal installation. The reproducing can be quite hard - installation preparation took more than two days...

No log files remained on the disk, but I've found yum transaction file. Attached.

Comment 12 David Shea 2013-12-20 15:06:12 UTC
The log files are in /tmp during installation. Please attach the files from there, in particular anaconda.log, packaging.log and program.log.

Comment 13 František Dvořák 2013-12-22 21:38:14 UTC
Created attachment 840465 [details]
log files from installation of Fedora 20 PPC64 under qemu

Comment 14 František Dvořák 2013-12-22 21:47:41 UTC
In this case, the problem is with launching of /usr/bin/p11-kit (called from update-ca-trust script).

If I understand the issue correctly, maybe it is more general problem of launching ppc64 binaries? (or maybe only when running under qemu?)

The bug about the chroot binary looks similar: https://bugzilla.redhat.com/show_bug.cgi?id=1045384

Comment 15 David Shea 2014-01-02 17:25:35 UTC
The signal 4 error messages indicate an attempt to execute an illegal instruction, so I'm going to say this is a problem with the emulator.

Comment 16 Paolo Bonzini 2014-01-23 11:35:43 UTC
This could be caused by QEMU's lack of support for the VSX SIMD extensions.

Comment 17 Paolo Bonzini 2014-01-23 11:36:09 UTC
*** Bug 1045384 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.